搜索之迷宫问题

Description

定义一个二维数组: 
int maze[5][5] = {

 0, 1, 0, 0, 0,

 0, 1, 0, 1, 0,

 0, 0, 0, 0, 0,

 0, 1, 1, 1, 0,

 0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<deque>
#include<list>
using namespace std;
int a[7][7],c[7][7],minn;
int b[5][5];
int moves[4][2]={0,-1,-1,0,0,1,1,0};/*显示*/
void display()
{
    int i,j;
    for(i=0;i<5;i++)
    for(j=0;j<5;j++)
    if(c[i][j]==1)
    printf("(%d, %d)\n",i,j);
}
void change()
{
    int i,j;
    for(i=0;i<5;i++)
    for(j=0;j<5;j++)
    c[i][j]=b[i][j];
}
void tyr(int i,int j,int count)//深度递归
{
    int k;
    if(i==4&&j==4)
    {
         if(count<minn)
         {
             minn=count;
             change();
         }
             return;          //一次递归完成
    }
    for(k=0;k<4;k++)
    {
        int nextx=i+moves[k][0];
        int nexty=j+moves[k][1];
        if(a[nextx][nexty]==0&&nextx>=0&&nexty>=0&&nextx<5&&nexty<5)
        {
            b[i][j]=1;
            a[i][j]=1;
            count++;
            tyr(nextx,nexty,count+1);
            count--;
            b[i][j]=0;
            a[i][j]=0;
        }
    }
}
int main()
{
    int i,j;
    minn=25;//先把最小赋值为25,每一步都走一次的步数
    memset(b,0,sizeof(b));
    memset(c,0,sizeof(c));
    for(i=0;i<5;i++)
    for(j=0;j<5;j++)
    cin>>a[i][j];
    b[4][4]=1;//最后的左下角出口出标记为1,原因最后dispay输出的是C[i][j]==1的坐标;
    tyr(0,0,1);
    display();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值