搜索之Tempter of the Bone

Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 
 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 
 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 
 

Sample Input

    
    
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output

    
    
NO YES
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<deque>
#include<list>
using namespace std;
int n,m,t;
char mg[10][10];
int f;
int sx,sy,dx,dy;
int moves[4][2]={-1,0,1,0,0,1,0,-1};
void dg(int x,int y,int count)
{
    //int k;
    if(x>=n||y>=m||x<0||y<0)//三个IF 是不能合并的,一开始时候合并了错了;问了大神才知道的
    return;
    if(x==dx&&y==dy&&count==t)
    f=1;
    if(f)
    return;
    for(int k=0;k<4;k++)
    {
        int nextx=x+moves[k][0];
        int nexty=y+moves[k][1];
        if(mg[nextx][nexty]!='X')//不能改成=='.';第一步和最后一个是‘S’一个是‘D’ 而不是'.';
        {
            mg[nextx][nexty]='X';
            dg(nextx,nexty,count+1);
            mg[nextx][nexty]='.';
        }
    }
}
int main()
{
    //int i,j;
    while((scanf("%d%d%d",&n,&m,&t)!=EOF) && (n!=0||m!=0||t!=0))//可以节省运行时间
    {
        //int count=0;
        for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        {
            cin>>mg[i][j];
            if(mg[i][j]=='S')
            {
                sx=i;
                sy=j;
            }
            if(mg[i][j]=='D')
            {
                dx=i;
                dy=j;
            }
        }
        if((abs(sx-dx)+abs(sy-dy))%2!=(t%2))
        {
            printf("NO\n");
            continue;
        }
        f=0;
        mg[sx][sy]='X';
        dg(sx,sy,0);
        if(f)
        printf("YES\n");
        else
        printf("NO\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值