Function Run Fun

Font Size: ← →

Problem Description

We all love recursion!  Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
  1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
  w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
  w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
     w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)


This is an easy function to implement.  The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

Source

冬练三九之一

#include<stdio.h>
int e[21][21][21];
int main()
{   
    int i,j,k;
    for(i=0;i<=20;i++)
    for(j=0;j<=20;j++)    //把所有的值计算出来 用e[i][j][k]记录
    for(k=0;k<=20;k++)
    {
        if(i==0||j==0||k==0) e[i][j][k]=1;      //因为if(a>20||b>20||c>20) return w(20,20,20);所以只有i<=20&&j<=20&&k<=20时才会有对应的值
    
    else
        if(i<j&&j<k)
            e[i][j][k]=e[i][j][k-1]+e[i][j-1][k-1]-e[i][j-1][k];
    
    else
            e[i][j][k]=e[i-1][j][k]+e[i-1][j-1][k]+e[i-1][j][k-1]-e[i-1][j-1][k-1];
    }

     int a,b,c,d;
    while(scanf("%d %d %d",&a,&b,&c)!=EOF)
    {
        if(a==-1&&b==-1&&c==-1) break;

      

      if(a<=0||b<=0||c<=0) d=1;
    else
      if(a>20||b>20||c>20) d=e[20][20][20];

      else
          d=e[a][b][c];



printf("w(%d, %d, %d) = %d\n",a,b,c,d);
        
    }


return 0;


}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值