A/B

A/B
Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 17
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input

数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output

对应每组数据输出(A/B)%9973。

Sample Input

2
1000 53
87 123456789

Sample Output

7922
6060

Author

xhd

Source

HDU 2007-1 Programming Contest
#include<stdio.h>
void gcd(int a, int b,int &x,int &y)    //  a*x+b*y==1  如果要求  a*x1+b*y1==n 中的 x1 只需要 x1=x*n
{	
	if (b == 0)
	{	
		x = 1;
		y = 0;
		return;		               //    return a;   求最大公约数     
	}		
	else
		gcd(b, a%b,x,y);
	int sum=x;
	x = y;
	y = sum - a / b*y;
}
int main()
{
	int  a,b=9973, x, y,n,t;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d%d", &n, &a);
		gcd(a ,b,x,y);
		x *= n;					 //  x   a*x+b*y==1  中的 x
		x = (x %b + b) % b;   //  防止 x 为负数
		printf("%d\n",x);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值