Romantic

Romantic
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 36   Accepted Submission(s) : 11
Font: Times New Roman | Verdana |Georgia
Font Size: ← →

Problem Description

The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

Input

The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

Author

yifenfei

Source

HDU女生专场公开赛——谁说女子不如男
#include<stdio.h>
__int64 c = 0;
__int64 gcd(__int64 a, __int64 b, __int64 &x, __int64 &y)    //  a*x+b*y==1  如果要求  a*x1+b*y1==n 中的 x1 只需要 x1=x*n
{	
	
	if (b == 0)
	{
		x = 1;
		y = 0;
		c = a;
		return c;    //    return a;   求最大公约数  
	}
		
	
	else
		gcd(b, a%b, x, y);
	__int64 sum = x;
	x = y;
	y = sum - a / b*y;
	return 0;
}
int main()
{
	__int64  a, b , x, y;

	while (scanf("%I64d%I64d", &a, &b)!=EOF)
	{
		
		gcd(a, b, x, y);
		if (c == 1)
		{	
			if (x < 0)  //  将产生的 负X  变为正数
			{	
				x = x + b;
				y = y-a;		
			}
			printf("%I64d %I64d\n", x, y);

		}			
		else 
			printf("sorry\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值