Minimum Inversion Number

Minimum Inversion Number

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 84   Accepted Submission(s) : 62
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
ZOJ Monthly, January 2003
 
#include <cstdio>
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
const int maxn = 55555;
int sum[maxn << 2], g[5010];
void PushUP(int rt)
{
	sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}
void build(int l, int r, int rt)  // 向上建树
{
	if (l == r)
	{
		sum[rt] = 0;  // 初始化   都存0
		return;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUP(rt);
}
void update(int p, int add, int l, int r, int rt)   //  P 处加上 add   单点更新
{
	if (l == r)
	{
		sum[rt] += add;
		return;
	}
	int m = (l + r) >> 1;
	if (p <= m) update(p, add, lson);
	else update(p, add, rson);
	PushUP(rt);
}
int query(int L, int R, int l, int r, int rt)   //   L  到  R 的和    线段求和
{
	if (L <= l && r <= R)
	{
		return sum[rt];
	}
	int m = (l + r) >> 1;
	int ret = 0;
	if (L <= m) ret += query(L, R, lson);
	if (R > m) ret += query(L, R, rson);
	return ret;
}
int main()
{
	int n, s, min;
	while (scanf("%d", &n) != EOF)
	{
		build(1, n, 1);
		s = 0;
		for (int i = 1; i <= n; i++)
		{	
			scanf("%d", &g[i]);
			s+=query(g[i]+1,n, 1, n, 1);    //  线段求和
			update(g[i]+1, 1, 1, n, 1);	    //  单点更新
		}
		min = s;
		for (int i = 1; i < n; i++)
		{
			s += n - 2 * g[i] - 1;   //   移动后的逆序书对
			if (s < min) min = s;
		}
		printf("%d\n", min);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值