hdu 2416 Treasure of the Chimp Island(bfs求最短路)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2416


Treasure of the Chimp Island

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 306    Accepted Submission(s): 148

Problem Description
Bob Bennett, the young adventurer, has found the map to the treasure of the Chimp Island, where the ghost zombie pirate LeChimp, the infamous evil pirate of the Caribbeans has hidden somewhere inside the Zimbu Memorial Monument (ZM 2). ZM 2 is made up of a number of corridors forming a maze. To protect the treasure, LeChimp has placed a number of stone blocks inside the corridors to block the way to the treasure. The map shows the hardness of each stone block which determines how long it takes to destroy the block. ZM 2 has a number of gates on the boundary from which Bob can enter the corridors. Fortunately, there may be a pack of dynamites at some gates, so that if Bob enters from such a gate, he may take the pack with him. Each pack has a number of dynamites that can be used to destroy the stone blocks in a much shorter time. Once entered, Bob cannot exit ZM 2 and enter again, nor can he walk on the area of other gates (so, he cannot pick more than one pack of dynamites).

The hardness of the stone blocks is an integer between 1 and 9, showing the number of days required to destroy the block. We neglect the time required to travel inside the corridors. Using a dynamite, Bob can destroy a block almost immediately, so we can ignore the time required for it too. The problem is to find the minimum time at which Bob can reach the treasure. He may choose any gate he wants to enter ZM 2.
 
Input
The input consists of multiple test cases. Each test case contains the map of ZM 2 viewed from the above. The map is a rectangular matrix of characters. Bob can move in four directions up, down, left, and right, but cannot move diagonally. He cannot enter a location shown by asterisk characters (*), even using all his dynamites! The character ($) shows the location of the treasure. A digit character (between 1 and 9) shows a stone block of hardness equal to the value of the digit. A hash sign (#) which can appear only on the boundary of the map indicates a gate without a dynamite pack. An uppercase letter on the boundary shows a gate with a pack of dynamites. The letter A shows there is one dynamite in the pack, B shows there are two dynamite in the pack and so on. All other characters on the boundary of the map are asterisks. Corridors are indicated by dots (.). There is a blank line after each test case. The width and the height of the map are at least 3 and at most 100 characters. The last line of the input contains two dash characters (--).
 
Output
For each test case, write a single line containing a number showing the minimum number of days it takes Bob to reach the treasure, if possible. If the treasure is unreachable, write IMPOSSIBLE.
 
Sample Input
  
  
*****#********* *.1....4..$...* *..***..2.....* *..2..*****..2* *..3..******37A *****9..56....* *.....******..* ***CA********** ***** *$3** *.2** ***#* --
 

Sample Output
  
  
1 IMPOSSIBLE
 

题意:输入一个字符矩阵;
   入口:'A'-'Z','#','#'代表不带炸弹进入,'A'代表带一个炸弹进入,以此类推
   终点:'$';
   数字代表进过该点有两种方式,a)炸掉,不付出代价通过;b),花费该数字的代价通过该点
   '.'代表不花费任何代价通过,'*'则代表不能通过

思路:用一个三位数组记录当前点的状态,因为每个数字点可以有两种方法通过,第三维表示当前点的炸弹数量,此题输入也值得注意

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define INF 9999999
using namespace std;
struct data
{
    int x,y;
    int bomb;
    int cost;
};
int row;
int col;
char mp[105][105];
int vis[105][105][26];
int result = INF;
int dir[4][2]= {0,1,1,0,-1,0,0,-1};

/*
bool operator<(data a,data b)
{
    return a.cost>b.cost;
}
*/
void bfs()
{
    memset(vis,-1,sizeof(vis));
    int i,j;
    data f;
    queue <data> qu;
    //入口
    for( i =0; i<row; i++)
    {
        for(j=0; j<col; j++)
        {

            if(mp[i][j]=='#' || (mp[i][j]>='A' && mp[i][j]<='Z'))
            {
                f.x=i;
                f.y=j;
                f.cost=0;
                if(mp[i][j]=='#') f.bomb=0;
                else f.bomb = mp[i][j]-'A'+1;
                qu.push(f);
                vis[i][j][f.bomb]=0;
                mp[i][j]='*';
            }
        }
    }
    //搜索
    while(!qu.empty())
    {
        data e;
        f = qu.front();
        qu.pop();
        for(i=0; i<4; i++)
        {
            e.x = f.x+dir[i][0];
            e.y = f.y+dir[i][1];

            if(mp[e.x][e.y]=='*' || e.x<0 || e.y<0 || e.x>=row || e.y>= col)
                continue;

            if(mp[e.x][e.y]=='.') //直接走过,时间不变,炸弹数不变
            {
                e.bomb=f.bomb;
                if(vis[e.x][e.y][e.bomb] == -1 || f.cost < vis[e.x][e.y][e.bomb])
                {
                    e.cost = f.cost;
                    vis[e.x][e.y][e.bomb] = f.cost;
                    qu.push(e);
                }
            }
            else if(mp[e.x][e.y]>='1' && mp[e.x][e.y]<='9')
            {
                //不炸,炸弹不变,时间加上mp[e.x][e.y]
                if(vis[e.x][e.y][f.bomb]==-1 || f.cost+mp[e.x][e.y]-'0' < vis[e.x][e.y][f.bomb])
                {
                    e.bomb = f.bomb;
                    e.cost = f.cost + mp[e.x][e.y]-'0';
                    vis[e.x][e.y][e.bomb]=e.cost;
                    qu.push(e);
                }
                //炸,炸弹数-1,时间不变;
                if(f.bomb>0)
                {
                    if(vis[e.x][e.y][f.bomb-1]==-1 || f.cost < vis[e.x][e.y][f.bomb-1])
                    {
                        e.bomb = f.bomb - 1;
                        e.cost = f.cost;
                        vis[e.x][e.y][e.bomb]=e.cost;
                        qu.push(e);
                    }
                }
            }
            /*else if(mp[e.x][e.y]=='$'&&f.cost<result)
                result = f.cost;*/
            else if(mp[e.x][e.y]=='$' && result > f.cost) //这个地方我找了一下午= =,找到$后,花费应该是前一步的,如果改成e.cost,则结果始终是0;
                result = f.cost;
        }
    }
}
int main()
{
    while(1)
    {
        row=0;
        while(gets(mp[row]))
        {
            if(mp[row][0]=='-')
                return 0;
            if(strlen(mp[row])<1)
                break;
            row++;
        }
        col=strlen(mp[0]);
        result=INF;
        bfs();
        if(result==INF) printf("IMPOSSIBLE\n");
        else printf("%d\n",result);
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过融合先进技术,如物联网、大数据、人工智能等,实现校园的智能化管理与服务。政策的推动和技术的成熟为智慧校园的发展提供了基础。该方案强调了数据的重要性,提出通过数据的整合、开放和共享,构建产学研资用联动的服务体系,以促进校园的精细化治理。 智慧校园的核心建设任务包括数据标准体系和应用标准体系的建设,以及信息化安全与等级保护的实施。方案提出了一站式服务大厅和移动校园的概念,通过整合校内外资源,实现资源共享平台和产教融合就业平台的建设。此外,校园大脑的构建是实现智慧校园的关键,它涉及到数据中心化、数据资产化和数据业务化,以数据驱动业务自动化和智能化。 技术应用方面,方案提出了物联网平台、5G网络、人工智能平台等新技术的融合应用,以打造多场景融合的智慧校园大脑。这包括智慧教室、智慧实验室、智慧图书馆、智慧党建等多领域的智能化应用,旨在提升教学、科研、管理和服务的效率和质量。 在实施层面,智慧校园建设需要统筹规划和分步实施,确保项目的可行性和有效性。方案提出了主题梳理、场景梳理和数据梳理的方法,以及现有技术支持和项目分级的考虑,以指导智慧校园的建设。 最后,智慧校园建设的成功依赖于开放、协同和融合的组织建设。通过战略咨询、分步实施、生态建设和短板补充,可以构建符合学校特色的生态链,实现智慧校园的长远发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值