HDU 1242 Rescue(BFS+优先队列)

93 篇文章 0 订阅
35 篇文章 0 订阅
 
Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

 

Input

 

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

 

Output

 

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

 

Sample Input

 

 
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

 

Sample Output

 

 
13
 

 

题意:X代表卫兵,a代表终点,r代表起始点,.代表路,#代表墙

路花费一秒,x花费两秒

问到达终点的最少时间

思路:BFS+优先队列

 

 

#include<cstdio>
#include<iostream>
#include<queue>
using namespace std;

int dx[4] = {-1, 1, 0, 0};
int dy[4] = {0, 0, -1, 1};

char map[220][220];
int n, m;

struct node
{
    int x, y, step;
    friend bool operator < (node a,node b)
    {
        return  a.step > b.step;
    }   //步数小的优先
}st, ed;

bool judge(int x, int y)  //判断能不能走这一步
{
    if(x >= 1 && x <= n && y >= 1 && y <= m && (map[x][y] == '.'  || map[x][y] == 'x' || map[x][y] == 'a'))
        return true;
    return false;
}

int bfs()
{
    priority_queue <node> que;
    map[st.x][st.y] = '#';
        que.push(st);
    int x, y, time, i;
    node tmp;
    while(!que.empty())
    {
        tmp = que.top();
        que.pop();
        x = tmp.x;
        y = tmp.y;
        time = tmp.step;
        for(i = 0; i < 4; i++)
        {
            tmp.x = x + dx[i];
            tmp.y = y + dy[i];
            if(judge(tmp.x,tmp.y))
            {
                if(map[tmp.x][tmp.y] == 'a')
                {
                    return time + 1;
                }
                if(map[tmp.x][tmp.y] == 'x')
                {
                    tmp.step = time + 2;
                   map[tmp.x][tmp.y] = '#';
                    que.push(tmp);
                }
                else if(map[tmp.x][tmp.y] == '.')
                {
                    tmp.step = time + 1;
                   map[tmp.x][tmp.y] = '#';
                    que.push(tmp);
                }
            }
        }
    }
    return -1;
}

int main()
{
    int i, j;
    while(~scanf("%d%d",&n,&m))
    {
        for(i = 1; i <= n; i++)
            for(j = 1; j <= m; j++)
            {
                cin >> map[i][j];
                if(map[i][j] == 'r')
                {
                    st.x = i;
                    st.y = j;
                    st.step = 0;
                }
                else if(map[i][j] == 'a')
                {
                    ed.x = i;
                    ed.y = j;
                }
            }
        int ans = bfs();
        if(ans == -1)
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}

 

 

 

 

 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值