Android Studio由于下载的SDK Tools版本造成无法更新SDK问题

由于Android studio的版本升级导致 Android SDK Tools package (25.2.3 and higher)版本变高从而使得我们不能够在Android studio里打开SDK Manager 进行设置代理,更新SDK.所以我们今天提供两种方法为大家解决这个问题

(我的开发环境为Ubuntu16.04)

1.第一下载一个SDK Tools package小于 25.2.3。
我这里可以提供一个。(tools)

http://download.csdn.net/download/u013763766/10218157

2.终端执行./tools/android 打开SDK Manager
这里写图片描述

3.点击tool->options->填写国内sdk更新源
1、东软信息学院
mirrors.neusoft.edu.cn 端口:80
2、北京化工大学
ubuntu.buct.edu.cn/ubuntu.buct.cn 端口:80
3、中国科学院开源协会
mirrors.opencas.cn (mirrors.opencas.org/mirrors.opencas.ac.cn) 端口:80
4、上海GDG镜像服务器
sdk.gdgshanghai.com 端口:8000
5、电子科技大学
mirrors.dormforce.net 端口:80
其中,强烈推荐电子科技大学的镜像源!
这里写图片描述

再次打开Android Studio SDKManager 就能更新SDK了。

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u013763766/article/details/79130273
个人分类: android
想对作者说点什么? 我来说一句

Android Studio里设置Build Tool版本

2017年02月15日 216KB 下载

没有更多推荐了,返回首页

不良信息举报

Android Studio由于下载的SDK Tools版本造成无法更新SDK问题

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭