HDU 1005Number Sequence

Description

A number sequence is defined as follows: 

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

Given A, B, and n, you are to calculate the value of f(n). 
 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed. 
 

Output

For each test case, print the value of f(n) on a single line. 
 

Sample Input

    
    
1 1 3 1 2 10 0 0 0
 

Sample Output

    
    
2 5 
找循环节
因为是mod 7,所以共有0~6,7种可能,又由于f(n)是由f(n-1)和f(n-2)决定的,所以在7*7=49,在50之内必定循环.
#include<stdio.h>
int main()
{
    int A,B,n;
    int s[50];
    while(scanf("%d%d%d",&A,&B,&n))
    {
        if(A==0&&B==0&&n==0)
            break;
        int i;
        s[1]=s[2]=1;
        for(i=3;i<=50;i++)
        {
            s[i]=(A*s[i-1]+B*s[i-2])%7;
            if(s[i]==1&&s[i-1]==1)
                break;
        }
        n=n%(i-2);
        if(n==0)
        printf("%d\n",s[i-2]);
        else
        printf("%d\n",s[n]);
    }
    return 0;
}

矩阵乘法和快速幂
#include<stdio.h>
#include<string.h>
int a,b,n;
int f[4];
int bina[32];
int comp(int p)
{
	int i=0;
	memset(bina,0,sizeof(bina));
	while(p)
	{
		if(p%2)
		{
			bina[i++]=1;
		}
		else
		{
			bina[i++]=0;
		}
		p/=2;
	}
	for(i=31;i>=0;i--)
	if(bina[i])
	break;
	return i;
}
void func(int len)
{
	int i;
	int a1,a2,a3,a4;
	int b1,b2,b3,b4;
	f[0]=0;f[1]=b;f[2]=1;f[3]=a;
	for(i=len-1;i>=0;i--)
	{
		a1=(f[0]*f[0]+f[1]*f[2])%7;
		a2=(f[0]*f[1]+f[1]*f[3])%7;
		a3=(f[2]*f[0]+f[3]*f[2])%7;
		a4=(f[2]*f[1]+f[3]*f[3])%7;
		if(bina[i])
		{
			b1=a2;
			b2=a1*b+a2*a;
			b3=a4;
			b4=a3*b+a4*a;
			a1=b1%7;
			a2=b2%7;
			a3=b3%7;
			a4=b4%7;
		}
		f[0]=a1;
		f[1]=a2;
		f[2]=a3;
		f[3]=a4;
	}
}
int main()
{
	while(scanf("%d %d %d",&a,&b,&n)!=EOF&&(a||b||n))
	{
		int len;
		if(n<3)
		{
			printf("1\n");
			continue;
		}
		else if(n==3)
		{
			printf("%d\n",a+b);
			continue;
		}
		len=comp(n-3);
		func(len);
		printf("%d\n",(f[1]+(a+b)*f[3])%7);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值