FZU1752快速幂取模+乘法的加速

Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3 2 4
2 10 1000

Sample Output

1
24
由于a,b,c都比较大  简单的快速幂取模算法中 的乘法得到的结果 比较大可能超  long long 的范围 
因此需要将乘法转换为二进制的加法
#include <iostream>
#include <cstdio>
using namespace std;
typedef unsigned long long LL;
//模拟乘法,把乘法变成二进制加法。
LL mul(LL a,LL b,LL m)//二分 求 a*b%m;
{
    LL res=0,tmp=a%m;
    while(b)
    {
        if(b&1)
            if((res+=tmp)>=m)
               res-=m;
        if((tmp<<=1)>=m)
            tmp-=m;
        b>>=1;
    }
    return res;
}
LL quick_mod(LL a,LL b,LL m)//二分求a^b%m
{
    LL ans = 1;
    a%=m;
    while(b)
    {
        if(b%2==1)
        {
            ans=mul(ans,a,m);
            b--;
        }
        b/=2;
        a=mul(a,a,m);
    }
    return ans;
}
int main()
{
    LL a,b,m;
    while(cin>>a>>b>>m){
        cout<<quick_mod(a,b,m)<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值