hdu1316(How Many Fibs?)高精度

Problem Description
Recall the definition of the Fibonacci numbers: 
f1 := 1 
f2 := 2 
fn := fn-1 + fn-2 (n >= 3) 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 
 

Sample Input
  
  
10 100 1234567890 9876543210 0 0
 

Sample Output
  
  
5 4
求给定的区间范围内 有多少个斐波那契数列
打表得到长度100以内的所有斐波那契数 然后与左右端点进行比较即可
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 570;
const int len =150;
char fib[N][len];
void Bigadd(char a[],char b[],char c[])
{
    int n=strlen(a);
    int m=strlen(b);
    char temp;
    int i,j,e,d;
    for(i=0; i<m/2; i++)
    {
        temp=b[i];
        b[i]=b[m-1-i];
        b[m-1-i]=temp;
    }
    for(i=0; i<n/2; i++)
    {
        temp=a[i];
        a[i]=a[n-1-i];
        a[n-1-i]=temp;
    }
        d=0;
        e=0;
    for(i=0;i<n&&i<m;i++)
    {
        d=a[i]-'0'+b[i]-'0'+e;
        c[i]=d%10+'0';
        e=d/10;
    }
    if(i==m)
    {
        for(;i<n;i++)
        {
            d=a[i]-'0'+e;
            c[i]=d%10+'0';
            e=d/10;
        }
    }
    if(i==n)
    {
        for(;i<m;i++)
        {
            d=b[i]-'0'+e;
            c[i]=d%10+'0';
            e=d/10;
        }
    }
    if(e)
        c[i++]=e+'0';
    int t=i;
    for(i=0; i<t/2; i++)
    {
        temp=c[i];
        c[i]=c[t-1-i];
        c[t-1-i]=temp;
    }
    for(i=0; i<m/2; i++)
    {
        temp=b[i];
        b[i]=b[m-1-i];
        b[m-1-i]=temp;
    }
    for(i=0; i<n/2; i++)
    {
        temp=a[i];
        a[i]=a[n-1-i];
        a[n-1-i]=temp;
    }
}
int cmp(char a[],char b[])
{
    int len1=strlen(a);
    int len2=strlen(b);
    if(len1==len2){
        return strcmp(a,b);
    }
    else if(len1>len2)
        return 1;
    return -1;
}
void init()
{
    fib[1][0]='1';
    fib[2][0]='2';
    for(int i=3;i<N;i++)
        Bigadd(fib[i-1],fib[i-2],fib[i]);
}
int main()
{
    char a[len],b[len];
    init();
    while(cin>>a>>b){
       if(a[0]=='0'&&b[0]=='0')
          break;
        int cnt=0;
        for(int i=1; i<N; i++)
        {
            if(cmp(fib[i],a)>=0&&cmp(fib[i],b)<=0)
                cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值