HDU1695(欧拉+容斥)

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5646    Accepted Submission(s): 2045


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 

Source
2008 “Sunline Cup” National Invitational Contest

题意:给定两个区间 [a,b],[c,d],在两个区间中分别区一个数,使得GCD(x,y)=k;
分析:很自然的我们可以想到GCD(x/k,y/k)=1;因此相当于在区间[1/k,b/k],[1/k,d/k]中取两区间中的元素x,y使得GCD(x,y)=1;
由于GCD(x,y)与GCD(y,x)是一样的,我们假设x<y,于是可以先取小区间中的。
由于GCD(X,Y)=1;所以小区间可以计算为
ans+=phi(1)+phi(2)+.....+phi(b/k);(假设b/k<d/k);
对于区间[b/k+1,d/k],设y为区间的一个元素,我们可以对y进行素因子分解,于是得到集合{p1,p2,p3,......},可以通过求gcd(x,y)!=1来求gcd(x,y)=1;中间需要用到容斥原来来进行统计能被这些素数整除的数的个数。
我们用b/k减去与i不互质的数的个数得到,求与i不互质的数的个数时就用到容斥原理,设i的素因子分别的p1,p2...pk,则1..b/k中p1的倍数组成集合A1,p2的倍数组成集合A2,p3到A3.....pk到Ak, 由于集合中会出现重复的元素, 所以用容斥原理来求A1并A2并A3.....并Ak的元素的数的个数.
A1并A2并A3并A4并..并.AK=一个因子的倍数的个数-两个因子的倍数的个数+三个因子的倍数的个数。。。。。。(奇加偶减)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

typedef long long LL;

const int maxn = 100001;

int num[maxn],p[maxn][20];//每个数的素因子个数,每个数的素因子
LL eular[maxn];//每个数的欧拉函数值之和

void init(){//筛发得到数的素因子
    eular[1]=1;
    for(int i=2;i<maxn;i++){
        if(!eular[i]){
            for(int j=i;j<maxn;j+=i){
                if(!eular[j])
                    eular[j]=j;
                eular[j]=eular[j]*(i-1)/i;
                p[j][num[j]++]=i;
            }
        }
        eular[i]+=eular[i-1];
    }
}

LL dfs(int id,int b,int now){//求不大于b的数中,与now不互质的数的个数;
    LL ans=0;
    for(int i=id;i<num[now];i++)//容斥原理来求A1并A2并A3.....并Ak的元素的数的个数.
        ans+=b/p[now][i]-dfs(i+1,b/p[now][i],now);
    return ans;
}

int main(){
    int t,a,b,c,d,k,ca=1;
    init();
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        printf("Case %d: ",ca++);
        if(k==0){
            puts("0");
            continue;
        }
        if(b>d)
            swap(b,d);
        b/=k,d/=k;
        LL ans=eular[b];
        for(int i=b+1;i<=d;i++)
            ans+=b-dfs(0,b,i);
        printf("%I64d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值