HDU 2647 Reward 【逆向建图+拓扑排序】

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4337    Accepted Submission(s): 1328


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 

Sample Output
  
  
1777 -1
 
/*
题解:逆向建图+拓扑排序,因为未初始化wrong了n次,汗!!!(初始化很重要啊)
*/
题意:若输入a,b,要求a必须比b的工资多且各员工最少工资为888。要求出最小工资,必须:
1.每条边的a比b多1
2.逆向建图方可统计最小工资前面的工资数目(正常拓扑无法统计,不需要优先队列)

#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
#define maxn 10002
using namespace std;
int n,m,iq,vis[maxn],in[maxn],sum[maxn];
__int64 cout;
vector<int>e[maxn];

int max(int a,int b)
{
	return a>b?a:b;
}
void topo()
{
    queue<int>q;
    for(int i=1; i<=n; i++)
	{
        if(in[i]==0) q.push(i);
    }
    while(!q.empty())
	{
        int x=q.front();
        q.pop();
        iq++;
        for(int i=0; i<e[x].size(); i++)
		{
            in[e[x][i]]--;
            if(in[e[x][i]]==0) q.push(e[x][i]);
             sum[e[x][i]]=max(sum[x]+1,sum[e[x][i]]); //如果当前的值比前驱加上一的值还小就要更新当前点的值
        }
    }
}

int main()
{
    int a,b;
    while(scanf("%d %d",&n,&m)!=EOF)
	{
        memset(in,0,sizeof(in));
        memset(sum,0,sizeof(sum));
		memset(e,0,sizeof(e));//未初始化wrong了n次
        while(m--)
		{
            scanf("%d %d",&a,&b); 
            e[b].push_back(a); 
            in[a]++;
        }
        iq=cout=0;
        topo();
        if(iq==n)
		{
            for(int i=1; i<=n; i++) cout+=sum[i];
                printf("%I64d\n",cout+888*n);
        }
        else printf("-1\n");
    }
    return 0;   
}

























评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值