HDU A Bug's Life

Problem Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

题目大意

有多组数据。每组数据第一行为n,m表示有n个人,m个关系

接下来m行,每行两个数表示a,b互为异性。

求关系是否冲突(如1与2异性,3与2异性,1与3异性则为冲突


Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input

  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output

  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.

题解

首先,这道题最坑的是每组输出之间还有一行空行。
这是一道基础种类并查集,用fa[i]表示同性的人的分类,sex[i]表示与i异性的人的分类代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cstdlib>
#include<cmath>
using namespace std;
int t,n,m,fa[2002],pd,sex[2002];//sex表示i 
int find(int x)
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
void set(int a,int b)
{
    a=find(a);
    b=find(b);
    if(a!=b)  fa[b]=a;
}
void doit(int w)
{
	pd=0;
	memset(sex,0,sizeof(sex));
	for(int i=1;i<=n;i++) fa[i]=i;
	for(int i=1;i<=m;i++)
	   {int a,b;
		scanf("%d%d",&a,&b);
		if(pd==1) continue; 
	    int r1=find(a),r2=find(b);
	    if(r1==r2)
		   {pd=1; continue;}
	    if(sex[a]==0) sex[a]=b;
        else set(sex[a],b);
        if(sex[b]==0) sex[b]=a;
        else set(sex[b],a);   
	   }
	printf("Scenario #%d:\n",w);
	if(pd==1) printf("Suspicious bugs found!\n");
	else printf("No suspicious bugs found!\n");
}
int main()
{
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	   {scanf("%d%d",&n,&m);
	    doit(i);
		printf("\n");
	   }
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值