POJ Shortest Prefixes

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

题目大意

给你至多1000个由小写字母组成的、长度不超过20的字符串,要求永不重复的且长度最小的前缀表示每个字符串。

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

题解

字典树模板。

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cmath>
using namespace std;
char a[1002][25];
int size=0,zz=0,trie[30001][26],cs[30001]/*cs表示这个位置被多少个字母经过*/;
void insert(char ch[])
{
	int w=0,l=strlen(ch+1),p=1,k;//l=strlen(ch+1)必须这么写 
	while(p<=l)
	   {cs[w]++;
	    k=ch[p]-'a';
	    if(!trie[w][k]) trie[w][k]=++size;
	    w=trie[w][k]; p++;
	   }
	cs[w]++;
}
void find(char ch[])
{
	int w=0,l=strlen(ch+1),p=1,k;
	while(p<=l)
	   {if(cs[w]==1&&w!=0) break;//
	    k=ch[p]-'a';
	    printf("%c",ch[p]);
	    w=trie[w][k]; p++;
	   }
}
int main()
{
	while(scanf("%s",a[++zz]+1)!=EOF) insert(a[zz]);
	//a[++zz]+1表示从第一位开始输入字符串。 
	for(int i=1;i<=zz;i++)
	   {printf("%s ",a[i]+1);
	    find(a[i]);
	    printf("\n");
	   }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值