POJ - 1324 Holedox Moving【状态压缩+A*】

Holedox Moving
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 17742 Accepted: 4175

Description

During winter, the most hungry and severe time, Holedox sleeps in its lair. When spring comes, Holedox wakes up, moves to the exit of its lair, comes out, and begins its new life. 
Holedox is a special snake, but its body is not very long. Its lair is like a maze and can be imagined as a rectangle with n*m squares. Each square is either a stone or a vacant place, and only vacant places allow Holedox to move in. Using ordered pair of row and column number of the lair, the square of exit located at (1,1). 

Holedox's body, whose length is L, can be represented block by block. And let B1(r1,c1) B2(r2,c2) .. BL(rL,cL) denote its L length body, where Bi is adjacent to Bi+1 in the lair for 1 <= i <=L-1, and B1 is its head, BL is its tail. 

To move in the lair, Holedox chooses an adjacent vacant square of its head, which is neither a stone nor occupied by its body. Then it moves the head into the vacant square, and at the same time, each other block of its body is moved into the square occupied by the corresponding previous block. 

For example, in the Figure 2, at the beginning the body of Holedox can be represented as B1(4,1) B2(4,2) B3(3,2)B4(3,1). During the next step, observing that B1'(5,1) is the only square that the head can be moved into, Holedox moves its head into B1'(5,1), then moves B2 into B1, B3 into B2, and B4 into B3. Thus after one step, the body of Holedox locates in B1(5,1)B2(4,1)B3(4,2) B4(3,2) (see the Figure 3). 

Given the map of the lair and the original location of each block of Holedox's body, your task is to write a program to tell the minimal number of steps that Holedox has to take to move its head to reach the square of exit (1,1). 

Input

The input consists of several test cases. The first line of each case contains three integers n, m (1<=n, m<=20) and L (2<=L<=8), representing the number of rows in the lair, the number of columns in the lair and the body length of Holedox, respectively. The next L lines contain a pair of row and column number each, indicating the original position of each block of Holedox's body, from B1(r1,c1) to BL(rL,cL) orderly, where 1<=ri<=n, and 1<=ci<=m,1<=i<=L. The next line contains an integer K, representing the number of squares of stones in the lair. The following K lines contain a pair of row and column number each, indicating the location of each square of stone. Then a blank line follows to separate the cases. 

The input is terminated by a line with three zeros. 

Note: Bi is always adjacent to Bi+1 (1<=i<=L-1) and exit square (1,1) will never be a stone. 

Output

For each test case output one line containing the test case number followed by the minimal number of steps Holedox has to take. "-1" means no solution for that case.

Sample Input

5 6 4
4 1
4 2
3 2
3 1
3
2 3
3 3
3 4

4 4 4
2 3
1 3
1 4
2 4
4

2 1
2 2
3 4
4 2

0 0 0

Sample Output

Case 1: 9
Case 2: -1

Hint

In the above sample case, the head of Holedox can follows (4,1)->(5,1)->(5,2)->(5,3)->(4,3)->(4,2)->(4,1)->(3,1)->(2,1)->(1,1) to reach the square of exit with minimal number of step, which is nine. 

Source


思路:

显然需要搜索,但是难点是如何保存状态。我们需要保存整个蛇身的状态,但是把每个节点的坐标都标记是不现实的。由于蛇身是相连的,我们可以标记一个蛇头的坐标,然后其他节点只标记其到前一个节点的方向,方向有4个,我们可以用4进制来表示。这样的4进制数最大为4^7。直接爆搜可以过。

可以用A*做。设g为蛇头到终点的曼哈顿距离,估价函数为step+g。用优先队列维护即可。


代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
#include<queue>
#include<stdlib.h>
#include<math.h>
using namespace std;
#define inf 0x3f3f3f3f
int n,m,L,beg[10][2],G[22][22];
bool vis[22][22][1<<14];
int dir[4][2]= {1,0,0,1,-1,0,0,-1};
struct node
{
    int y,x,step,h,g;
    int body[10][2];
    bool operator <(node a)const
    {
        return a.step+a.g<step+g;
    }
}p;
int getf(int sty,int stx,int edy,int edx)
{
    int ty=edy-sty;
    int tx=edx-stx;
    for(int i=0; i<4; i++)
    {
        if(ty==dir[i][0] && tx==dir[i][1])
            return i;
    }
}
int bfs()
{
    priority_queue<node> q;
    memset(vis,0,sizeof vis);
    int h=0;
    for(int i=1; i<L; i++)
    {
        h=h*4+getf(beg[i][0],beg[i][1],beg[i-1][0],beg[i-1][1]);
    }
    p.y=beg[0][0];
    p.x=beg[0][1];
    p.h=h;
    p.step=0;
    p.g=p.x+p.y;
    memcpy(p.body,beg,sizeof beg);
    vis[p.y][p.x][h]=1;
    q.push(p);
    while(!q.empty())
    {
        node top=q.top(); q.pop();
        if(top.y==0 && top.x==0) return top.step;
        for(int i=0;i<4;i++)
        {
            int ty=top.y+dir[i][0];
            int tx=top.x+dir[i][1];
            if(ty<0 || ty>=n || tx<0 || tx>=m || G[ty][tx])
                continue;
            int flag=0;
            for(int j=0;j<L;j++)
                if(ty==top.body[j][0] && tx==top.body[j][1])
                {
                    flag=1;
                    break;
                }
            if(flag) continue;
            int h=(top.h>>2)+i*(1<<(2*L-4));
            for(int j=1;j<L;j++)
            {
                p.body[j][0]=top.body[j-1][0];
                p.body[j][1]=top.body[j-1][1];
            }
            p.body[0][0]=ty;
            p.body[0][1]=tx;

            if(vis[ty][tx][h]) continue;
            vis[ty][tx][h]=1;
            p.y=ty;
            p.x=tx;
            p.h=h;
            p.g=ty+tx;
            p.step=top.step+1;
            q.push(p);
        }
    }
    return -1;
}
int main()
{
    int cas=1;
    while(scanf("%d%d%d",&n,&m,&L) && n+m+L)
    {
        for(int i=0; i<L; i++)
        {
            scanf("%d%d",&beg[i][0],&beg[i][1]);
            beg[i][0]--;
            beg[i][1]--;
        }
        int k;
        memset(G,0,sizeof G);
        scanf("%d",&k);
        for(int i=0;i<k;i++)
        {
            int y,x;
            scanf("%d%d",&y,&x);
            G[y-1][x-1]=1;
        }
        printf("Case %d: %d\n",cas++,bfs());
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值