POJ - 2823 Sliding Window【单调队列优化dp && c++快读】

Sliding Window

Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 72718 Accepted: 20659
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

<span style="color:#000000">8 3
1 3 -1 -3 5 3 6 7
</span>

Sample Output

<span style="color:#000000">-1 -3 -3 -3 3 3
3 3 5 5 6 7
</span>

Source

POJ Monthly--2006.04.28, Ikki

 

思路:

从区间[L,R]转移到区间[L+1,R+1]时,我们可以利用之前的信息。

求区间最小值时,我们可以维护一个单调递增的队列。我们可以用数组模拟队列,并开一个辅助数组记录队列中相应元素的下标。

添加数据时,可以把队列后面所有大于等于它的全部舍弃掉,把数据入队。删除数据时,只需要把队首元素下标小于当前区间左边界的删除即可。

c++快速读入:

cin.tie(0);
std::ios::sync_with_stdio(false);

代码:

#include <stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
#define MAXN 1000005
int n,k,a[MAXN],tmp[MAXN],que[MAXN],dpmin[MAXN],dpmax[MAXN];
void DPmin()
{
    int head=1,tail=0;
    for(int i=0; i<n; i++)
    {
        while(tmp[head]<i-k+1 && head<=tail) head++;
        while(head<=tail && que[tail]>=a[i]) tail--;
        que[++tail]=a[i];
        tmp[tail]=i;
        dpmin[i]=que[head];
    }
}
void DPmax()
{
    int head=1,tail=0;
    for(int i=0; i<n; i++)
    {
        while(tmp[head]<i-k+1 && head<=tail) head++;
        while(head<=tail && que[tail]<=a[i]) tail--;
        que[++tail]=a[i];
        tmp[tail]=i;
        dpmax[i]=que[head];
    }
}
int main()
{
    cin.tie(0);
    std::ios::sync_with_stdio(false);
    cin>>n>>k;
    for(int i=0; i<n; i++)
        cin>>a[i];
    DPmin();
    DPmax();
    for(int i=k-1; i<n; i++)
    {
        if(i>k-1) cout<<" ";
        cout<<dpmin[i];
    }
    cout<<"\n";
    for(int i=k-1; i<n; i++)
    {
        if(i>k-1) cout<<" ";
        cout<<dpmax[i];
    }
    cout<<"\n";
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值