HDU 5305 Friends(2015多校第二场 dfs + 剪枝)

Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 552    Accepted Submission(s): 253


Problem Description
There are   people and   pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these   people wants to have the same number of online and offline friends (i.e. If one person has   onine friends, he or she must have   offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer  , indicating the number of testcases. 

For each testcase, the first line contains two integers   and  , indicating the number of people and the number of pairs of friends, respectively. Each of the next   lines contains two numbers   and  , which mean   and   are friends. It is guaranteed that   and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
  
  
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
  
  
0 2
 

Source
解题思路:
注意到数据范围很小,因此,暴力搜索+ 剪枝即可。
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN = 30;
int x[MAXN],y[MAXN], s[MAXN], s1[MAXN], s2[MAXN], g[MAXN][MAXN];
int n, m;
int ans;
void dfs(int dep)
{
    if(dep > m)
    {
        for(int i=1;i<=n;i++)
        {
            if(s1[i] != s2[i])
                return ;
        }
        ans++;
        return ;
    }
    int u = x[dep], v = y[dep];
    if(s1[u] < s[u] / 2 && s1[v] < s[v] / 2)
    {
        s1[u]++; s1[v]++;
        dfs(dep + 1);
        s1[u]--; s1[v]--;
    }
    if(s2[u] < s[u] / 2 && s2[v] < s[v] / 2)
    {
        s2[u]++; s2[v]++;
        dfs(dep + 1);
        s2[u]--; s2[v]--;
    }
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &n, &m);
        memset(g, 0, sizeof(g));
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d", &x[i], &y[i]);
            g[x[i]][y[i]] = g[y[i]][x[i]] = 1;
        }
        int flag = 1;
        for(int i=1; i<=n; i++)
        {
            s[i] = s1[i] = s2[i] = 0;
            for(int j=1; j<=n; j++)
            {
                if(i != j && g[i][j] == 1)
                    s[i]++;
            }
            if(s[i] & 1) flag = 0;
        }
        if(!flag)
        {
            printf("0\n");
            continue;
        }
        ans = 0;
        dfs(1);
        printf("%d\n", ans);
    }
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值