HDU 5355 Cake(2015多校第六场,搜索 + 剪枝)

Cake

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 965    Accepted Submission(s): 119
Special Judge


Problem Description
There are  m  soda and today is their birthday. The  1 -st soda has prepared  n  cakes with size  1, 2, \dots, n . Now  1 -st soda wants to divide the cakes into  m  parts so that the total size of each part is equal. 

Note that you cannot divide a whole cake into small pieces that is each cake must be complete in the  m  parts. Each cake must belong to exact one of  m  parts.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains two integers  n  and  m   (1 \le n \le 10^5, 2 \le m \le 10) , the number of cakes and the number of soda.
It is guaranteed that the total number of soda in the input doesn’t exceed 1000000. The number of test cases in the input doesn’t exceed 1000.
 

Output
For each test case, output "YES" (without the quotes) if it is possible, otherwise output "NO" in the first line.

If it is possible, then output  m  lines denoting the  m  parts. The first number  s_i  of  i -th line is the number of cakes in  i -th part. Then  s_i numbers follow denoting the size of cakes in  i -th part. If there are multiple solutions, print any of them.
 

Sample Input
  
  
4 1 2 5 3 5 2 9 3
 

Sample Output
  
  
NO YES 1 5 2 1 4 2 2 3 NO YES 3 1 5 9 3 2 6 7 3 3 4 8
 

Source
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <vector>
#include <queue>
#include <set>
#include <stack>
#include <algorithm>
#define LL long long
using namespace std;
const LL MAXN = 500000 + 10;
LL n, m;
LL ans[20][MAXN];
LL A[MAXN];
LL pos[MAXN];
LL tot, tar;
bool dfs(LL dep, LL now, LL u, LL c)
{
    if(now == 0)
    {
        LL k = 0;
        while(pos[k] != -1) k++;
        pos[k] = c;
        if(dfs(dep + 1, A[k], k + 1, c)) return true;
        pos[k] = -1;
        return false;
    }
    if(now == tar)
    {
        if(dep == tot) return true;
        if(dfs(dep, 0, 0, c + 1)) return true;
    }
    for(LL i=u;i<tot;i++)
    {
        if(pos[i] == -1 && now + A[i] <= tar)
        {
            pos[i] = c;
            if(dfs(dep + 1, now + A[i], i + 1, c)) return true;
            pos[i] = -1;
        }
    }
    return  false;
}
int main()
{
    LL T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &n, &m);
        for(LL i=0;i<m;i++) for(LL j=0;j<n;j++) ans[i][j] = 0;
        if((n * (n + 1) / 2) % m != 0 || (2 * m - 1) > n)
        {
            printf("NO\n");
            continue;
        }
        while(n >= 40)
        {
            for(LL i=0;i<m;i++) ans[i][++ans[i][0]] = n - i;
            for(LL i=0;i<m;i++) ans[i][++ans[i][0]] = n - 2 * m + 1 + i;
            n -= 2 * m;
        }
        tot = n;
        tar = n * (n + 1) / (2 * m);
        for(LL i=0;i<tot;i++) A[i] = tot - i;
        for(LL i=0;i<tot;i++) pos[i] = -1;
        dfs(0, 0, 0, 0);
        for(LL i=0;i<tot;i++) ans[pos[i]][++ans[pos[i]][0]] = A[i];
        printf("YES\n");
        for(LL i=0;i<m;i++)
        {
            printf("%d", ans[i][0]);
            for(LL j=1;j<=ans[i][0];j++) printf(" %d", ans[i][j]);
            printf("\n");
        }
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值