BZOJ 4001[TJOI2015]概率论

4001: [TJOI2015]概率论

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 583   Solved: 294
[ Submit][ Status][ Discuss]

Description

Input

输入一个正整数N,代表有根树的结点数

Output

 输出这棵树期望的叶子节点数。要求误差小于1e-9

Sample Input

1

Sample Output

1.000000000

HINT

 1<=N<=10^9

解题思路:

手动推了前5个,发现规律 ans = n * (n + 1) / 2 / (2 * n - 1);

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <algorithm>
#define LL long long 
using namespace std;
const int MAXN = 1000 + 10;
double N;
int main()
{
    scanf("%lf", &N);
    double ans = (N * (N + 1)) / 2.0 / (2.0 * N - 1.0); 
    printf("%.9lf\n", ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值