POJ 1915 Knight Moves(BFS+STL)


                          Knight Moves
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 20913 Accepted: 9702

Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

                      

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#define maxn 350
using namespace std;

int n;
int x1,x2,y1,y2;


struct node{
    int x;
    int y;
    int sum;
    node(int a,int b,int c)
    {
        x=a;
        y=b;
        sum=c;
    }

};

int go[8][2]={{1,2},{1,-2},{2,1},{2,-1},{-1,2},{-1,-2},{-2,1},{-2,-1}};
int vis[310][310];

int BFS()
{
    queue<node> que;
    memset(vis,0,sizeof vis);
    que.push(node(x1,y1,0));
    vis[x1][y1]=1;
    while(!que.empty())
    {
        node temp=que.front();
        for(int i=0;i<8;i++)
        {
            int x0=temp.x+go[i][0];
            int y0=temp.y+go[i][1];
            int sum0=temp.sum+1;
            if(x0>=0&&x0<n&&y0>=0&&y0<n)
            {
                if(x0==x2&&y0==y2) return sum0;
                else if(!vis[x0][y0])
                {
                    que.push(node(x0,y0,sum0));
                    vis[x0][y0]=1;
                }
            }
        }
        que.pop();
    }

    return 0;

}



int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d%d",&n,&x1,&y1,&x2,&y2);

        if(x1==x2&&y1==y2)
            printf("0\n");
        else
            printf("%d\n",BFS());
    }

    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
WPF 国际象棋 棋子ChessProgrammingTest.zip 要求: You have been provided with a third-party library "ChessLib" which calculates the legal moves a knight can make given a position on an 8 by 8 board. The library has been used to create a program which moves a knight randomly around a board, given an initial starting position and a total number of moves to make. Problem: ======== Extend this program to set up an 8 by 8 square game board containing several different pieces in predefined positions. For each move of the game, the program will choose a piece at random, and move it to a randomly selected valid position. You are not allowed to change any of the ChessLib code. Extend the program as required. Use Object Oriented Design and Modeling appropriately for extensibility. Please supply all the code for your solution in the file Answer.cs in the SampleProgram project. Please supply all the tests for your solution in the file TestAnswer.cs in the SampleProgram.Test project. Game Rules: ----------- * Only one piece can occupy any position on the board at a given time. * All pieces can “jump” any occupied position. Note: Although the game bears a striking resemblance to Chess, this is entirely coincidental. Do not assume other chess rules apply. Game Pieces to support: ----------------------- * Knight – Moves as implemented by ChessLib * Bishop - Moves diagonally, any distance within board boundaries * Queen – Moves diagonally, horizontally or vertically, any distance within board boundaries
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值