做的第一个大数问题,头疼在memset()函数:A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 210231    Accepted Submission(s): 40490


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 


 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 


 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 


 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 


 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
#include<stdio.h>
#include<string.h>
int main()
{
	int t,i,j,k,l,p;
	int q=0;
	char a[1010],b[1010];
	int c[1010]={0},d[1010]={0};
	scanf("%d",&t);
	//getchar();
	while(t--)
	{
		q++;
		memset(a,0,sizeof(char));
		memset(b,0,sizeof(char));
		
		<span style="color:#6633ff;BACKGROUND-COLOR: #ffffff">memset(c,0,sizeof(c));
		memset(d,0,sizeof(d));
       // memset(c,0,sizeof(int));
		//memset(d,0,sizeof(int));       此处错误,sizeof()内是需要清零的数组总长度 
        //memset(c,0,sizeof(int)*1010);  上下两种均可,切记 ,,切记 ,, 
		//memset(d,0,sizeof(int)*1010);
</span>		scanf("%s",a);
		scanf("%s",b);
		k=strlen(a);
		l=strlen(b);  
		for(i=k-1,j=0;i>=0;j++,i--)
             c[j]=a[i]-'0';       
		for(i=l-1,j=0;i>=0;j++,i--)
              d[j]=b[i]-'0';    		
		for(i=0;i<1010;i++)
		{
			c[i]=c[i]+d[i];
			if(c[i]>=10)
			{
				c[i]=c[i]%10;c[i+1]++;
			}
		}
		for(i=1010-1;c[i]==0&&i>=0;i--);//第二次做此题,就错在1010没减1,导致正确答案前面有好多0输出。如下部:	
		printf("Case %d:\n",q);
		printf("%s + %s = ",a,b);
		if(i>=0)
			for(;i>=0;i--)
			{
				printf("%d",c[i]);
			}
    	else
			printf("0");
		printf("\n");
		if(t)
		printf("\n");
	}
	return 0;
} 

111111
999999
90000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000001111110


 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值