xcode 低版本 要运行 iOS高的系统 真机测试

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u014128241/article/details/54345215

iOS102.

Could not locate device support files.
This iPhone 6s is running iOS 10.2(14C92), which may not be supported by this version of Xcode.

见文知意,主要原因是在调试前我将iOS 升级到了最新版10.2版本,而我的Xcode8.1支持的最高版本是10.1的。

其实每次iOS SDK版本升级都会遇到相同的问题,之前遇到过相同的问题,我都是直接更新Xcode。由于我需要立即测试程序,所以不允许去下载新的Xcode。

解决方法:

这里只以我的开发环境为参照,具体情况要按开发环境来看

1、复制一份旧的SDK,并重新命名为真机测试需要的SDK版本;

找到路径:
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk
(提示:要在应用程序中找到Xcode,右键点击 -> 显示包内容,以前Xcode版本的iOS SDK有的保存在系统根目录下)

复制一份iPhoneOS.sdk,并命名为iPhoneOS10.2.sdk
(里面的iPhoneOS10.1.sdk应该是系统创建来适配iOS10.1的)
这里写图片描述

2、修改

打开路径:
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport
这里我在网上找到了iOS10.2的真机调试包:
https://pan.baidu.com/s/1eSJtpXC
如果没用新的真机调试包,也可以这样做
找到:10.1(14B72) (这个是我的xcode中SDK的最高版本,如果没有这个也可以选择其他的)复制一份,并创新命名为真机需要的版本10.2(14C89)
这里写图片描述

3、修改SDKSettings.plist文件中的版本号

打开复制后的文档路径:SDKs/iPhoneOS10.2.sdk/SDKSettings.plist
将里面所有跟版本有关的数字都修改为10.2

这样可以在真机上运行了!

阅读更多
换一批

没有更多推荐了,返回首页