Friday the Thirteenth(模拟)

Friday the Thirteenth

Is Friday the 13th really an unusual event?

That is, does the 13th of the month land on a Friday less often than on any other day of the week? To answer this question, write a program that will compute the frequency that the 13th of each month lands on Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday over a given period of N years. The time period to test will be from January 1, 1900 to December 31, 1900+N-1 for a given number of years, N. N is positive and will not exceed 400.

Note that the start year is NINETEEN HUNDRED, not 1990.

There are few facts you need to know before you can solve this problem:

  • January 1, 1900 was on a Monday.
  • Thirty days has September, April, June, and November, all the rest have 31 except for February which has 28 except in leap years when it has 29.
  • Every year evenly divisible by 4 is a leap year (1992 = 4*498 so 1992 will be a leap year, but the year 1990 is not a leap year)
  • The rule above does not hold for century years. Century years divisible by 400 are leap years, all other are not. Thus, the century years 1700, 1800, 1900 and 2100 are not leap years, but 2000 is a leap year.

Do not use any built-in date functions in your computer language.

Don't just precompute the answers, either, please.

PROGRAM NAME: friday

INPUT FORMAT

One line with the integer N.

SAMPLE INPUT (file friday.in)

20

OUTPUT FORMAT

Seven space separated integers on one line. These integers represent the number of times the 13th falls on Saturday, Sunday, Monday, Tuesday, ..., Friday.

SAMPLE OUTPUT (file friday.out)

 

36 33 34 33 35 35 34 

 

     题意:

     输入数字N,N不超过400,输出1900年1月1到,1900+N-1年12月31号里,每个月的第13号是星期几,最后以星期6 7 1 2 3 4 5这个顺序输出总共天数。

     思路:

     从1900年1月13号算起,每过一个月就加上相应月份的天数,得出来的总体天数对7取余即可得出星期几,对应的星期几可用数组表示来累计算出,直到1900+N-1年12月31号为止(两个FOR)。要注意的是最后一次循环会多加一个月份,所以最后还要减去最后一次算出来的星期几。

   

 First and wrong:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
	int from=1900,N,i,j,sum;
	int date[7];
	memset(date,0,sizeof(date));
	sum=13;
	date[sum%7]++;
	 scanf("%d",&N);
	for(i=from;i<=from+N-1;i++)
	 {
	 	for(j=1;j<=12;j++)
	 	 {
	 	 	if(j==1||j==3||j==5||j==7||j==8||j==10||j==12)  sum+=31;
	 	 	if(j==4||j==6||j==9||j==11) sum+=30;
	 	 	if(j==2)
	 	 	{
	 	 		if((i%400==0)||((i%4==0&&i%100!=0))) sum+=29;
	 	 		else sum+=28;
	 	 	}

//   写完后,发现得出来的结果不正确,所以想观察一下前几项输出情况来看看正不正确 	  
//		printf("\n%d %d\n",sum,sum%7);     
//	 	  system("pause");
		   
		   date[sum%7]++;
		 }
	 }
	date[sum%7]--;                     //最后一次要减回来 
	printf("%d %d ",date[6],date[0]);  //不是7是0,粗心
	for(i=1;i<=5;i++)
	 {
	  printf("%d",date[i]);
	  i==5?printf("\n"):printf(" ");
     }
}

 

AC finally:

 

/*
TASK:friday
LANG:C
ID:sum-g1
*/
#include<stdio.h>
#include<string.h>
int main()
{
	FILE *fin =fopen("friday.in", "r");
        FILE *fout=fopen("friday.out", "w");
        int from=1900,N,i,j,sum;
	int date[7];
	memset(date,0,sizeof(date));
	sum=13;
	date[sum%7]++;
	 fscanf(fin,"%d",&N);
	for(i=from;i<=from+N-1;i++)
	 {
	 	for(j=1;j<=12;j++)
	 	 {
	 	 	if(j==1||j==3||j==5||j==7||j==8||j==10||j==12)  sum+=31;
	 	 	if(j==4||j==6||j==9||j==11) sum+=30;
	 	 	if(j==2)
	 	 	{
	 	 		if((i%400==0)||((i%4==0&&i%100!=0))) sum+=29;
	 	 		else sum+=28;
	 	 	}
	 	  	   
		   date[sum%7]++;
		 }
	 }
	date[sum%7]--;                           //最后一次要减回来
	fprintf(fout,"%d %d ",date[6],date[0]);  //星期日是0,不是7....  
	for(i=1;i<=5;i++)
	 {
	  fprintf(fout,"%d",date[i]);
	  i==5?fprintf(fout,"\n"):fprintf(fout," ");
     }
   exit(0);
}

 

 总结:

   题目虽然简单,但是还是很粗心,花的时间太长了,不能因为简单就随便对待,错误一定要自己找出来,无论花多长时间。 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
《Thomas微积分早期超越函数论,第十三版》是一本深受欢迎的教材,用于大学微积分课程。它被广泛用于讲授微积分的基本概念和技巧,旨在帮助学生理解微积分以及其在数学和实际应用中的重要性。 这本教材的第十三版是对之前版本的改进和更新。它首先介绍了基本的微积分原理,如导数和积分,然后深入讲解了微分和积分的应用,例如微分方程和曲线的长度和面积计算。此外,该书还介绍了多元函数、向量值函数和曲线及曲面积分等高级主题。 与之前的版本不同,这本书采用了现代化的教学方法和创新的教学工具。它包含了大量的图表、插图和实例,以便帮助学生更好地理解概念,并直观地应用所学知识。此外,书中还包含了习题和练习题,以便学生加深对概念和技巧的理解,并提供自我评估的机会。 这本教材在教学界享有很高的声誉,被广泛使用。它清晰明了地解释了微积分的关键概念,并给出了实际应用的例子,使学生能够将所学的知识应用到实际问题中。此外,书中还附有解答和附录,方便学生查阅。 总之,《Thomas微积分早期超越函数论,第十三版》是一本全面、易于理解且实用的教材,适用于学习微积分的任何学生。无论是对于希望深入了解微积分的专业学生,还是对于对数学感兴趣的非数学专业学生,这本书都是一本不可多得的学习资源。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值