HDU 1698——Just a Hook(线段树,区间修改)


Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17013    Accepted Submission(s): 8479


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.



_______________________________________________________分割线______________________________________________

Dota屠夫的钩子是由很多段组成的,初始为 铜的,每段的价值为1,

操作是:

把某段变成银的, 价值为2

把某段变为金的,价值为3

求经过m次操作后,屠夫的钩子好多钱羡慕


线段树区间修改入门,用lazy标记





<span style="font-size:18px;">#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define M 100001
#define l(x) x<<1
#define r(x) x<<1|1
using namespace std;
int n,m;
struct seg
{
    int l,r,f;                               //f为1表示是铜的,2是银的,3是金的,-1表示该段区间包含好多种金属
}t[M<<2];

void push_down(int u)                     //lazy
{
    if(t[u].f!=-1){                     //要修改的区间前面被改过
        t[l(u)].f=t[r(u)].f=t[u].f;    //把标记传递给左右儿子
        t[u].f=-1;                    //把父亲标记为-1,说明这段区间有好多种金属
    }
}
void build(int u,int l,int r)      //建树
{
    t[u].l=l;
    t[u].r=r;
    t[u].f=1;                  //初始为铜的,所以为1
    if(l==r) return;
    int m=(l+r)>>1;
    build(l(u),l,m);
    build(r(u),m+1,r);
}

void update(int u,int i,int j,int v)
{
    if(i<=t[u].l&&t[u].r<=j){          //如果当前区间包含于要更新的区间,修改该区间的f
        t[u].f=v;
        return ;
    }
    push_down(u);                    //否则,更新左右区间
    int m=(t[u].l+t[u].r)>>1;
    if(i<=m) update(l(u),i,j,v);
    if(m<j) update(r(u),i,j,v);
}

int query(int u)
{
    if(t[u].f!=-1) return t[u].f*(t[u].r-t[u].l+1);     //该区间的值为长度乘以f
    else return query(l(u))+query(r(u));
}

int main()
{
    int T,cas=1;
    cin>>T;
    while(T--){
        scanf("%d %d",&n,&m);
        build(1,1,n);
        int x,y,v;
        while(m--){
            scanf("%d %d %d",&x,&y,&v);
            update(1,x,y,v);
        }
        printf("Case %d: The total value of the hook is %d.\n",cas++,query(1));
    }
    return 0;
}</span>






















010

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值