uva 10014 - Simple calculations

The Problem

There is a sequence of n+2 elements a0, a1,…, an+1 (n <= 3000; -1000 <=  ai 1000). It is known that ai = (ai–1 + ai+1)/2 – ci   for each i=1, 2, ..., n. You are given a0, an+1, c1, ... , cn. Write a program which calculates a1.

The Input

The first line is the number of test cases, followed by a blank line.

For each test case, the first line of an input file contains an integer n. The next two lines consist of numbers a0 and an+1 each having two digits after decimal point, and the next n lines contain numbers ci (also with two digits after decimal point), one number per line.

Each test case will be separated by a single line.

The Output

For each test case, the output file should contain a1 in the same format as a0 and an+1.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

1150.5025.5010.15

Sample Output

27.85

A[i]=(A[i-1]+A[i+1])/2-C[i];
2*(A[i]+C[i])=A[i-1]+A[i+1]

A[1]-A[0]=A[2]-A[1]-2*C[1]
A[2]-A[1]=A[3]-A[2]-2*C[2]
...
A[i]-A[i-1]=A[i+1]-A[i]-2*C[i]
A[i]-A[0]=A[i+1]-A[1]-2C

A[1]=A[i+1]-A[i]+A[0]-2C(N)[N项和]
做到这没思路了,估计大多数人都和我一样Y-Y,只要再累加下去答案就出来了。
成功就是坚持做已经做过的事情O(∩_∩)O哈哈~
n=1  A[1]=A[2]-A[1]+A[0]-2C(1)
n=2  A[1]=A[3]-A[2]+A[0]-2C(2)
n=3  A[1]=A[4]-A[3]+A[0]-2C(3)
n*A[1]=A[n+1]-A[1]+n*A[0]-2*[c(1)+...C(n)]

(n+1)A[1]=A[n+1]+N*A[0]-2*[c(1)+c(n)]

1. 尽量推出a[1]与各项之间的关系

2 分数化整数

#include <stdio.h>
#include <math.h>
void main()
{
    double c[3001],s[3001],x,y;
    int n,i,t;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&n);
        scanf("%lf%lf",&x,&y);
        for (i=1;i<=n;i++)
            scanf("%lf",&c[i]);
        s[1]=c[1]; 
        s[0]=s[1];
        for (i=2;i<=n;i++)
            {
                s[i]=s[i-1]+c[i];
                s[0]+=s[i];
            }   
    printf("%.2lf\n",(n*x+y-2*s[0])/(n+1));
    if (t) printf("\n");
    }
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值