1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

#include <iostream>
#include <vector>
#include <cstdio>
using namespace std;

int main()
{
    int Na, Nb, tmp1, a_first, b_first;
    double tmp2;
    scanf("%d",&Na);
    vector<double> a(1001);
    for (int i = 0; i < Na; i++)
    {
        scanf("%d %lf", &tmp1, &tmp2);
        a[tmp1] = tmp2;
        if (i == 0)
            a_first = tmp1;
    }

    scanf("%d", &Nb);
    vector<double> b(1001);
    for (int i = 0; i < Nb; i++)
    {   
        scanf("%d %lf", &tmp1, &tmp2);
        b[tmp1] = tmp2;
        if (i == 0)
            b_first = tmp1;
    }

    int length = a_first + b_first + 1;
    vector<double> c(length);
    for (int i = 0; i < length; i++)
        c[i] = 0;

    int count = 0;

    for (int i = 0; i < a_first+1; i++)
        for (int j = 0; j < b_first+1; j++)
        {
            c[i + j] = c[i + j] + a[i] * b[j];
        }

    for (int i = 0; i < length;i++)
    {
        if (c[i] != 0)
            count++;
    }

    printf("%d", count);
    while (length)
    {       
        if (c[length-1]!=0)
            printf(" %d %.1f", length-1, c[length-1]);
        length--;
    }
    system("pause");
    return 0;
}

做完才发现多用了一个数组,两个数组就可以了:

for(int i = 0; i < Nb; i++) {
        scanf("%d %lf", &tmp1, &tmp2);
        for(int j = 0; j < 1001; j++)
                b[j + tmp1] += a[j] * tmp2;
    }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
图像识别技术在病虫害检测中的应用是一个快速发展的领域,它结合了计算机视觉和机器学习算法来自动识别和分类植物上的病虫害。以下是这一技术的一些关键步骤和组成部分: 1. **数据收集**:首先需要收集大量的植物图像数据,这些数据包括健康植物的图像以及受不同病虫害影响的植物图像。 2. **图像预处理**:对收集到的图像进行处理,以提高后续分析的准确性。这可能包括调整亮度、对比度、去噪、裁剪、缩放等。 3. **特征提取**:从图像中提取有助于识别病虫害的特征。这些特征可能包括颜色、纹理、形状、边缘等。 4. **模型训练**:使用机器学习算法(如支持向量机、随机森林、卷积神经网络等)来训练模型。训练过程中,算法会学习如何根据提取的特征来识别不同的病虫害。 5. **模型验证和测试**:在独立的测试集上验证模型的性能,以确保其准确性和泛化能力。 6. **部署和应用**:将训练好的模型部署到实际的病虫害检测系统中,可以是移动应用、网页服务或集成到智能农业设备中。 7. **实时监测**:在实际应用中,系统可以实时接收植物图像,并快速给出病虫害的检测结果。 8. **持续学习**:随着时间的推移,系统可以不断学习新的病虫害样本,以提高其识别能力。 9. **用户界面**:为了方便用户使用,通常会有一个用户友好的界面,显示检测结果,并提供进一步的指导或建议。 这项技术的优势在于它可以快速、准确地识别出病虫害,甚至在早期阶段就能发现问题,从而及时采取措施。此外,它还可以减少对化学农药的依赖,支持可持续农业发展。随着技术的不断进步,图像识别在病虫害检测中的应用将越来越广泛。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值