UVA - 673 - Parentheses Balance (栈的应用!)

UVA - 673

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF


  Parentheses Balance 

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct,  () and  [] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input 

The file contains a positive integer  n and a sequence of  n strings of parentheses  () and  [], one string a line.

Output 

A sequence of  Yes or  No on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

Sample Output 

Yes
No
Yes



Miguel Revilla
2000-08-14

Source

Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 2. Data Structures and Libraries :: Data Structures With Built-in Libraries ::  STL stack
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Data Structures and Libraries :: Linear Data Structures with Built-in Libraries ::  C++ STL stack (Java Stack)
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Rare Topics :: Rare Problems ::  Bracket Matching
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 2. Data Structures ::  Lists
Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 6. Data Structures ::  Exercises



简单栈的应用。。判断括号是否匹配

没看到空字符,WA了两次。。


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
using namespace std;

int main()
{
	int n;
	while(scanf("%d", &n) != EOF)
	{
		getchar();
		while(n--)
		{
			char a[130];
			stack<char> s;
			gets(a);
			int flag = 0;
			for(int i=0; a[i] != '\0'; i++)
			{
				if(a[i] == '(' || a[i] == '[') s.push(a[i]);
				else if(a[i] == ')') 
				{
					if(!s.empty() && s.top() == '(') s.pop();
					else { flag = 1; break; }
				}
				else if(a[i] == ']')
				{
					if(!s.empty() && s.top() == '[') s.pop();
					else { flag = 1; break; }
				}
			}
			if(flag || !s.empty()) printf("No\n");
			else printf("Yes\n");
		}
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值