UVA - 10420 - List of Conquests (排序 - qsort、STL)

42 篇文章 0 订阅
5 篇文章 0 订阅

UVA - 10420

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu

Submit Status

Description

Download as PDF

Problem B
List of Conquests
Input: 
standard input
Output: 
standard output
Time Limit: 
2 seconds

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina, il catalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000 lines, but the first. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3 
Spain Donna Elvira 
England Jane Doe 
Spain Donna Anna 

Sample Output

England 1 

Spain 2


Problem-setter: Thomas Tang, Queens University, Canada

 

 

“Failure to produce a reasonably good and error free problem set illustrates two things a) Lack of creativity b) Lack of commitment”

Source

Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 1. Elementary Problem Solving ::  Sorting/Searching
Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 1. Introduction ::  Ad Hoc
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: String Processing :: Ad Hoc String Processing Problems ::  Frequency Counting
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Introduction :: Ad Hoc Problems - Part 1 ::  Easy

Submit Status





思路:一个人在多个国家有爱人,输入每一组包括一个国家和爱人,算出每个国家的爱人数并输出,输出按照字典序


AC代码①(qsort的做法):

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath> 
using namespace std;

char na[100], name[100];

struct node {
	char name[100];
	int cnt;
};

struct node nation[2005];

int cmp(const void *a, const void *b) {
	return strcmp(((node*)a)->name, ((node*)b)->name);
}

int main() {
	int T, num = 0;
	scanf("%d", &T);
	while(T--) {
		scanf("%s", na);
		gets(name);
		
		int flag = 0;
		for(int i = 0; i < num; i ++) {
			if(strcmp(na, nation[i].name) == 0) {
				flag = 1;
				nation[i].cnt++;
				break;
			}
		}
		if(!flag) {
			nation[num].cnt = 1;
			strcpy(nation[num].name, na);
			num++;
		}
	}
	qsort(nation, num, sizeof(node), cmp);
	for(int i = 0; i < num; i++) {
		printf("%s %d\n", nation[i].name, nation[i].cnt);
	}
	return 0;
}



AC代码②(STL中map的做法):

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <algorithm>
#include <cmath> 
#include <map>
using namespace std;

char na[100], tmp[100];

map<string, int> nation;

int main() {
	int T, num = 0;
	scanf("%d", &T);
	while(T--) {
		scanf("%s", na);
		gets(tmp);
		if(nation.count(na)) nation[na]++;
		else nation[na] = 1;
	}
	for(map<string, int> :: iterator it = nation.begin(); it != nation.end(); it++) {
		cout << it->first << ' ' << it->second <<endl;
	}
	return 0;
}



AC代码③(STL中map的做法2,注意输出):

#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath> 
#include <map>
using namespace std;

char na[100], tmp[100];

map<string, int> nation;

int main() {
	int T, num = 0;
	scanf("%d", &T);
	while(T--) {
		scanf("%s", na);
		gets(tmp);
		if(nation.count(na)) nation[na]++;
		else nation[na] = 1;
	}
	for(map<string, int> :: iterator it = nation.begin(); it != nation.end(); it++) {
		printf("%s %d\n", it->first.c_str(), it->second);
	}
	return 0;
}




AC代码④(sort,待续。。):














  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值