UVA - 439 - Knight Moves (BFS)

43 篇文章 0 订阅
25 篇文章 0 订阅

UVA - 439

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

Source

Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Rare Topics :: Rare Problems ::  Knight Moves
Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 4. Graph :: Breadth First Search ::  SSSP on Unweighted Graph
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 2. Data Structures ::  Graphs
Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 6. Data Structures ::  Exercises
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Graph :: Single-Source Shortest Paths (SSSP) ::  On Unweighted Graph: BFS

 Status






思路:题目意思看了半天才懂,就是类似象棋中的马走日,可以朝八个方向走,然后给出两个点,问从一个点到另一点最短步数为多少,可以用BFS来搜索,一步一步模拟过去


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

char s1[5], s2[5];
int ans;
int vis[10][10];//记忆化搜索 
int dir[8][2] = {{-2, -1},{-2, 1},{-1, 2},{1, 2},{2, 1},{2, -1},{1, -2},{-1, -2}};//朝八个方向 

struct node {
	int x, y, count;		//count用于记录现在是第几层 
	bool operator == (const node &a) const {	//字符重载,用于快速比较 
		return x == a.x && y == a.y;
	} 
};

int bfs(node pos1, node pos2) {		//广搜 
	queue<node> q;
	node pre, cur;
	q.push(pos1);
	vis[pos1.x][pos1.y] = 1;
	while(!q.empty()) {
		pre = q.front();
		q.pop();
		if(pre == pos2) return pre.count;//找到后返回一个值(BFS层数,第几步) 
		for(int i = 0; i < 8; i++) {
			node cur;
			cur.x = pre.x + dir[i][0];
			cur.y = pre.y + dir[i][1];
			if(!vis[cur.x][cur.y] && cur.x >= 1 && cur.x <= 8 && cur.y >= 1 && cur.y <= 8) {
				vis[cur.x][cur.y] = 1;
				cur.count = pre.count + 1;
				q.push(cur);
			}
		}
	}
	return 0;
}

int main() {
	while(scanf("%s %s", s1, s2) != EOF) {
		node pos1, pos2;
		pos1.y = s1[0] - 'a' + 1;
		pos1.x = s1[1] - '0';
		pos1.count = 0;
		pos2.y = s2[0] - 'a' + 1;
		pos2.x = s2[1] - '0';
		pos2.count = 0;
		
		memset(vis, 0, sizeof(vis));
		ans = bfs(pos1, pos2);
		printf("To get from %s to %s takes %d knight moves.\n", s1, s2, ans);
	} 
	return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值