HDU 1086 You can Solve a Geometry Problem too(线段交点个数)

You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7349    Accepted Submission(s): 3575


Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point. 
 

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the number of intersections, and one line one case.
 

Sample Input
  
  
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
 

Sample Output
  
  
1 3
题意为,每行给你一条线段的两个点(x1,y1),(x2,y2),求这些线段的交点的个数
第一种方法为根据两点的直线公式,求出直线方程,把另外两点分别带入直线方程,看两个结果是否为异号,是则为交点
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <stdio.h>
#include<math.h>
using namespace std;
struct node
{
    double x1,y1,x2,y2;
}a[105];
int yice(node a,node b)
{
    double s1,s2;
    s1=b.x1*(a.y2-a.y1) + a.x2*a.y1-a.x1*a.y2 - b.y1*(a.x2-a.x1);  //两点间的距离公式(x-x1)/(x2-x1)=(y-y1)/(y2-y1)化简后,带入一个端点
    s2=b.x2*(a.y2-a.y1) + a.x2*a.y1-a.x1*a.y2 - b.y2*(a.x2-a.x1);   //带另一个端点
    if(s1<=0&& s2>=0)        //异号则存在交点
        return 1;
    else if(s1>=0 && s2<=0)
          return 1;
    else return 0;
}
int main()
{
    int n,i,j;
    while(scanf("%d",&n),n)
     {
         for(i=0;i<n;i++)
         scanf("%lf%lf%lf%lf",&a[i].x1,&a[i].y1,&a[i].x2,&a[i].y2);
         int ans=0;
         for(i=0;i<n;i++)
         for(j=0;j<n;j++)
             {
                 if(i!=j)
                 {
                     if(yice(a[i],a[j])&&yice(a[j],a[i]))  // 因为题目给的是线段,则对于两条线段,前者给的两点必须在后者线段的两侧,反之亦如此,这样保证了有交点
                        ans++;
                 }
             }

         printf("%d\n",ans/2);  //重复计算了一次,需/2
     }
    return 0;
}
</pre><pre name="code" class="html">
第二种直接上模板
</pre><pre name="code" class="html"><pre name="code" class="html">#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include <math.h>
#define eps 1e-8
#define zero(x) (((x)>0?(x):-(x))<eps)
struct point
{
    double x,y;
}q[105];
struct line
{
    point a,b;
}w[1000];
double xmult(point p1,point p2,point p0)
{
	return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
int same_side(point p1,point p2,line l)
{
	return xmult(l.a,p1,l.b)*xmult(l.a,p2,l.b)>eps;
}
int dots_inline(point p1,point p2,point p3)
{
	return zero(xmult(p1,p2,p3));
}
int dot_online_in(point p,line l)
{
	return zero(xmult(p,l.a,l.b))&&(l.a.x-p.x)*(l.b.x-p.x)<eps&&(l.a.y-p.y)*(l.b.y-p.y)<eps;
}
int intersect_in(line u,line v)
{
	if (!dots_inline(u.a,u.b,v.a)||!dots_inline(u.a,u.b,v.b))
		return !same_side(u.a,u.b,v)&&!same_side(v.a,v.b,u);
	return dot_online_in(u.a,v)||dot_online_in(u.b,v)||dot_online_in(v.a,u)||dot_online_in(v.b,u);
}

int main()
{   int sum=0,i,n,j;
    while(scanf("%d",&n),n)
    {
        sum=0;
    for(i=1;i<=n;i++)
    {
        scanf("%lf%lf%lf%lf",&q[1].x,&q[1].y,&q[2].x,&q[2].y);
        w[i].a=q[1];
        w[i].b=q[2];
    }
    for(i=1;i<=n;i++)
    {
        for(j=i+1;j<=n;j++)
        {

            sum+=intersect_in(w[i],w[j]);
        }
    }
    printf("%d\n",sum);
    }
    return 0;
}




 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值