POJ A Knight's Journey(DFS)

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31324 Accepted: 10708

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 
一道经典的DFS,行为1~7,列为A~G,问给定的n*m的棋盘上,马能否遍历整个棋盘(按字典序输出路径)
#include <iostream>
#include <cstring>
#include <cstdio>
#include <stdlib.h>
using namespace std;
int n,m,e,bis;
int xx[]= {-2,-2,-1,-1,1,1,2,2};
int yy[]= {-1,1,-2,2,-2,2,-1,1};

char s[15000];
int b[150][150];
void dfs(int x,int y)
{
     if(bis)
        return ;
    b[x][y]=1;
    s[e++]=x+'A'-1;
    s[e++]=y+'0';
    if(m*n*2 == e)
    {
        bis=1;
        return ;
    }
    for(int i=0; i<8; i++)
    {
        int tx=x+xx[i];
        int ty=y+yy[i];
        if(tx>0 && tx<=m && ty>0 && ty<=n && !b[tx][ty])
        {
            if(!bis)
            {
                dfs(tx,ty);
                e=e-2;
                b[tx][ty]=0;
            }

        }
    }
}
int main()
{
    int T;
    cin>>T;
    for(int i=1; i<=T; i++)
    {
        bis=0;
        e=0;
        cin>>n>>m;
        memset(b,0,sizeof(b));
        dfs(1,1);
        printf("Scenario #%d:\n",i);
        if(bis)
            printf("%s\n\n",s);
        else printf("impossible\n\n");
    }
    return 0;

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值