POJ 1159 Palindrome(LCS~~回文)

17 篇文章 0 订阅
Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 54092 Accepted: 18689

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2
 
 
最少补充的字母数 = 原序列的长度 —  原串和逆序的最长公共子串长度
如果最长公共子串长度==原序列长度,则是回文,反之须补充的数目为n-lcs;
 
// 49180K  1188MS
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
using namespace std;
const int N = 5002;
int n;
short int dp[N][N];         // int开不出,会暴内存
int main()
{
    while(~scanf("%d%*c",&n))
    {
        char s1[N],s2[N];
        for(int i=1; i<=n; i++)
        {
            scanf("%c",&s1[i]);
            s2[n-i+1]=s1[i];
        }
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                if(s1[i]==s2[j])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                }
            }
        printf("%d\n",n-dp[n][n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值