POJ 3687 Labeling Balls(拓扑排序)

15 篇文章 0 订阅
Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12180 Accepted: 3490

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4
给出编号1~n 的n个球的重量(a,b),即编号a的球重量大于b
输出各个球在这n个球中是第几重,如果多种结果,使编号靠前的球尽量轻(反正我是理解错了。。。)
逆向拓扑排序,一组数据
5 3
1 4
4 2
3 5
正向拓扑的结果为 1 4 2 3 5
即最轻的是1号球 其次是3号球,4 ,2, 5号球
反向的结果为 1 3 4 2 5
与正向不同的是 2号球的排名由4变为了3
显然第二种才是正解
#include <iostream>
#include <stdlib.h>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 201
using namespace std;
int a[N][N],ans[N],v[N];
int n,m;
void Solve()
{
    int i,j,k;
    for(i=n;i>=1;i--)
    {
        for(j=n;j>=1;j--)
        {
            if(v[j]==0)
            {
                ans[j]=i;
                v[j]--;
                for(k=1;k<=n;k++)
                {
                    if(a[j][k])
                    {
                        v[k]--;
                    }
                }
                break;
            }
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int i;
        int x,y;
        scanf("%d%d",&n,&m);
        memset(a,0,sizeof(a));
        memset(v,0,sizeof(v));
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            if(a[y][x]==0)
            {
                a[y][x]=1;
                v[x]++;
            }
        }
        Solve();
        bool flag=true;
        for(int i=1;i<=n;i++)
        {
            if(v[i]!=-1)
            {
                flag=false;
                break;
            }
        }
        if(!flag)
        {
            printf("-1\n");
            continue;
        }
        for(i=1;i<=n;i++)
        {
            if(i==1) printf("%d",ans[i]);
            else printf(" %d",ans[i]);
        }
        printf("\n");

    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值