HDU 5384 Danganronpa(AC自动机模式串重复)

Danganronpa

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 478    Accepted Submission(s): 267


Problem Description
Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series' name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are  n  verbal evidences, and Stilwell has  m  "bullets". Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings  Ai , and bullets are some strings  Bj . The damage to verbal evidence  Ai  from the bullet  Bj  is  f(Ai,Bj) .
f(A,B)=i=1|A||B|+1[ A[i...i+|B|1]=B ]
In other words,  f(A,B)  is equal to the times that string  B  appears as a substring in string  A .
For example:  f(ababa,ab)=2 f(ccccc,cc)=4

Stilwell wants to calculate the total damage of each verbal evidence  Ai  after shooting all  m  bullets  Bj , in other words is  mj=1f(Ai,Bj) .
 

Input
The first line of the input contains a single number  T , the number of test cases.
For each test case, the first line contains two integers  n m .
Next  n  lines, each line contains a string  Ai , describing a verbal evidence.
Next  m  lines, each line contains a string  Bj , describing a bullet.

T10
For each test case,  n,m105 1|Ai|,|Bj|104 |Ai|105 |Bj|105
For all test case,  |Ai|6105 |Bj|6105 Ai  and  Bj  consist of only lowercase English letters
 

Output
For each test case, output  n  lines, each line contains a integer describing the total damage of  Ai  from all  m  bullets,  mj=1f(Ai,Bj) .
 

Sample Input
  
  
1 5 6 orz sto kirigiri danganronpa ooooo o kyouko dangan ronpa ooooo ooooo
 

Sample Output
  
  
1 1 0 3 7
输入n,m表示有n个目标串,要输出n个匹配的结果,m是指有m个模式串(其中有重复的字符串,需要利用map记录其出现的次数,计算时出现次数*该字符串匹配的结果)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <map>
#define N 100010
using namespace std;
string s1[N];
string s2[N];
map<string ,int>sq;
struct Trie
{
    int next[N][26],fail[N],end[N];
    int b,root;
    int newnode()
    {
        for(int i=0; i<26; i++)
            next[b][i]=-1;
        end[b++]=-1;
        return b-1;
    }
    void init()
    {
        b=0;
        root=newnode();
    }
    void insert(string s,int id)
    {
        int now=root;
        int len=s.length();
        for(int i=0; i<len; i++)
        {
            if(next[now][s[i]-'a']==-1)
                next[now][s[i]-'a'] = newnode();
            now = next[now][s[i]-'a'];
        }
        end[now] = id;
    }
    void build()
    {
        queue<int >q;
        fail[root]=root;
        for(int i=0; i<26; i++)
        {
            if(next[root][i]==-1)
                next[root][i]=root;
            else
            {
                fail[next[root][i]] = root;
                q.push(next[root][i]);
            }
        }
        while(!q.empty())
        {
            int now = q.front();
            q.pop();
            for(int i=0; i<26; i++)
            {
                if(next[now][i]==-1)
                    next[now][i] = next[fail[now]][i];
                else
                {
                    fail[next[now][i]] = next[fail[now]][i];
                    q.push(next[now][i]);
                }
            }
        }
    }
    void query(string s,int m)
    {
        int len=s.length();
        int now=root;
        int sum[N];
        memset(sum,0,sizeof(sum));

        for(int i=0; i<len; i++)
        {
            now=next[now][s[i]-'a'];
            int temp = now;
            while(temp != root)
            {
                if(end[temp]!=-1)
                {
                    sum[end[temp]]++;   
                }
                temp = fail[temp];
            }
        }
        int ans=0;
        for(int i=0; i<m; i++)
        {
            if(sum[i])
            {
                ans+= sum[i] * sq[s2[i]];
            }
        }
        printf("%d\n",ans);
    }
};
Trie ac;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
        {
            cin>>s1[i];
        }
        ac.init();
        sq.clear();                 //每次操作前清空map
        for(int i=0; i<m; i++)
        {
            cin>>s2[i];
            if(sq[s2[i]]!=0)       //利用map记录每个匹配串出现的次数
            {
                sq[s2[i]]++;
            }
            else
            {
                sq[s2[i]]=1;
                ac.insert(s2[i],i);
            }
        }
        ac.build();
        for(int i=0; i<n; i++)
        {
            ac.query(s1[i],m);
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值