2013山东省第三届ACM省赛 Pick apples

34 篇文章 6 订阅

Pick apples

Time Limit: 1000MS Memory limit: 165536K

题目描述

Once ago, there is a mystery yard which only produces three kinds of apples. The number of each kind is infinite. A girl carrying a big bag comes into the yard. She is so surprised because she has never seen so many apples before. Each kind of apple has a size and a price to be sold. Now the little girl wants to gain more profits, but she does not know how. So she asks you for help, and tell she the most profits she can gain.

输入

In the first line there is an integer T (T <= 50), indicates the number of test cases.
In each case, there are four lines. In the first three lines, there are two integers S and P in each line, which indicates the size (1 <= S<= 100) and the price (1 <= P <= 10000) of this kind of apple.

In the fourth line there is an integer V,(1 <= V <= 100,000,000)indicates the volume of the girl's bag.

输出

For each case, first output the case number then follow the most profits she can gain.

示例输入

1
1 1
2 1
3 1
6

示例输出

Case 1: 6


题意:给出三种苹果的体积s和价值p,给出一个总体积V,求出能得到的最大价值。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;

struct node{
    long long S;
    long long P;
    double q;
}a[3];

bool cmp(node a,node b){
    return a.q>b.q;
}

int main(){

    int T;
    long long V;
    long long sum;
    long long dp[6000];
    long long tmp;
    int i,j;
    int ca=0;


    scanf("%d",&T);

    while(T--){
        scanf("%lld%lld",&a[0].S,&a[0].P);
        a[0].q=(double)(a[0].P)/a[0].S;
        //cout<<a[0].q<<endl;
        scanf("%lld%lld",&a[1].S,&a[1].P);
        a[1].q=(double)(a[1].P)/a[1].S;
        //cout<<a[1].q<<endl;
        scanf("%lld%lld",&a[2].S,&a[2].P);
        a[2].q=(double)(a[2].P)/a[2].S;
        //cout<<a[2].q<<endl;
        scanf("%lld",&V);

        sort(a,a+3,cmp);

        sum=V%a[0].S;

        for(i=1;;++i){
            if(a[0].S*i>=5000){
                break;
            }
        }

        sum=sum+a[0].S*i;

        memset(dp,0,sizeof(dp));

        for(i=0;i<3;++i){
            for(j=a[i].S;j<=sum;++j){
                tmp=dp[j-a[i].S]+a[i].P;
                if(tmp>dp[j]){
                    dp[j]=tmp;
                }
            }
        }

        for(i=sum;;--i){
            if(dp[i]>0){
                break;
            }
        }

        printf("Case %d: %lld\n",++ca,((V-sum)/a[0].S)*a[0].P+dp[i]);

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值