UVA 10036 Divisibility

原题传送门:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=977

 

 

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions:

 

17+5+-21+15=16
17+5+-21-15=-14
17+5--21+15=58
17+5--21-15=28
17-5+-21+15=6
17-5+-21-15=-24
17-5--21+15=48
17-5--21-15=18

 

We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.

 

You are to write a program that will determine divisibility of sequence of integers.

 

Input

 

The first line of the input file contains a integer M indicating the number of cases to be analyzed. Then M couples of lines follow. 
For each one of this couples, the first line contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value.

 

Output

 

For each case in the input file, write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

 

Sample input

 

2
4 7
17 5 -21 15
4 5
17 5 -21 15

 

Sample Output

 

Divisible
Not divisible

分析:
DP

 

•f[i][j]=1表示前i个数字形成的表达式的值除以K之后可以余j

 

•f[0][0]=1

 

•考虑第i个数字x,假设它是正的。

 

•如果 f[i-1][j] = 1,说明前i-1个数字的表达式的值除以K可以余j

 

•在x的前面放“+”, f[i][(j+x)%K] = 1

 

•在x的前面放“-”,f[i][(j-x+K)%K]=1
 
#include<cstdio>
#include<cstring>
int t,n,k,num,cur;
bool dp[2][100];
int main(){
    scanf("%d",&t);
    while(t--){
        cur = 0;
        memset(dp,false,sizeof(dp));
        dp[0][0] = true;
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++){
            cur ^= 1;
            memset(dp[cur],false,sizeof(dp[cur]));
            scanf("%d",&num);
            if(i>1 && num<0)
                num = -num;
            num %= k;
            for(int j=0;j<k;j++){
                if(dp[cur^1][j]){
                    dp[cur][(j+num+k)%k] = true;
                    if(i>1)dp[cur][(j-num+k)%k] = true;
                }
            }
        }
        printf("%s\n",dp[cur][0]?"Divisible":"Not divisible");
    }

    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值