HDU 1757 A Simple Math Problem

原题传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1757

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2480    Accepted Submission(s): 1441


Problem Description

 

Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

 

Input

 

The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

 

Output

 

For each case, output f(k) % m in one line.
 

 

Sample Input
10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0
 

 

Sample Output
45
104
 

 

Author

 

linle
 

 

Source

 

 

 

 

Recommend

 

lcy   |   We have carefully selected several similar problems for you:   1588  3117  2276  2256  2604
分析:这道题如果用打表或者递归肯定都是TLE的,那么我们可以用什么办法解决呢。。答案当然是矩阵快速幂。关键在于矩阵怎么构造了= =,这个矩阵也不难构造,就拿第一个例子来说,我们可以构造矩阵
1  1  1  1  1  1  1  1  1  1
    1            0
         1
    0       。
                      。
                               1   0
只要学过矩阵乘法运算,估计都应该已经知道怎么回事了!
 
#include<cstdio>
#include<cstring>
int k,m,ans;
struct Matrix{
    int mat[10][10];
    Matrix operator *(const Matrix rhs) const {
        Matrix temp;
        for(int i=0;i<10;i++){
            for(int j=0;j<10;j++){
                temp.mat[i][j] = 0;
                for(int k=0;k<10;k++){
                    temp.mat[i][j] += (this->mat[i][k] * rhs.mat[k][j])%m;
                    temp.mat[i][j] %= m;
                }
            }
        }
        return temp;
    }
};

Matrix ret,mt;
int main(){
    while(~scanf("%d%d",&k,&m))
    {
        ans = 0;
        memset(ret.mat,0,sizeof(ret.mat));
        memset(mt.mat,0,sizeof(mt.mat));
        for(int i=0;i<10;i++)
            ret.mat[i][i] = 1;
        for(int i=0;i<10;i++)
            scanf("%d",&mt.mat[0][i]);
        for(int i=1;i<10;i++)
            mt.mat[i][i-1] = 1;
        k = k-9;
        while(k)
        {
            if(k&1) ret = ret * mt;
            k>>=1;
            mt = mt*mt;
        }
        for(int i=0;i<10;i++)
            ans = (ans + ret.mat[0][i]*(9-i))%m;
        printf("%d\n",ans);
    }

    return 0;
}
内容概要:本文档详细介绍了一个利用Matlab实现Transformer-Adaboost结合的时间序列预测项目实例。项目涵盖Transformer架构的时间序列特征提取与建模,Adaboost集成方法用于增强预测性能,以及详细的模型设计思路、训练、评估过程和最终的GUI可视化。整个项目强调数据预处理、窗口化操作、模型训练及其优化(包括正则化、早停等手段)、模型融合策略和技术部署,如GPU加速等,并展示了通过多个评估指标衡量预测效果。此外,还提出了未来的改进建议和发展方向,涵盖了多层次集成学习、智能决策支持、自动化超参数调整等多个方面。最后部分阐述了在金融预测、销售数据预测等领域中的广泛应用可能性。 适合人群:具有一定编程经验的研发人员,尤其对时间序列预测感兴趣的研究者和技术从业者。 使用场景及目标:该项目适用于需要进行高质量时间序列预测的企业或机构,比如金融机构、能源供应商和服务商、电子商务公司。目标包括但不限于金融市场的波动性预测、电力负荷预估和库存管理。该系统可以部署到各类平台,如Linux服务器集群或云计算环境,为用户提供实时准确的预测服务,并支持扩展以满足更高频率的数据吞吐量需求。 其他说明:此文档不仅包含了丰富的理论分析,还有大量实用的操作指南,从项目构思到具体的代码片段都有详细记录,使用户能够轻松复制并改进这一时间序列预测方案。文中提供的完整代码和详细的注释有助于加速学习进程,并激发更多创新想法。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值