hdu 1518 Square

Square

                                                                                Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                 Total Submission(s): 8250    Accepted Submission(s): 2684


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 

Source



题意:给出n条边长看是否能组成一个正方形

方法:深搜加剪枝  

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,a[25],vis[25],sum;
int cmp(int a,int b)
{
    return a>b;
}
int dfs(int l,int x,int ans)
{
    int i;
    if(ans==3)
        return 1;
    for(i=x;i<n;i++)
    {
        if((l+a[i]<=sum/4)&&!vis[i])
        {
            vis[i]=1;
            int s=l+a[i];
            if(s==sum/4)
            {
                if(dfs(0,0,ans+1))
                    return 1;
            }
            else if(dfs(s,i+1,ans))
                  return 1;

                   vis[i]=0;
        }

    }

    return 0;
}
int main()
{
    int cas,i;
    scanf("%d",&cas);
    while(cas--)
    {
       sum=0;
        scanf("%d",&n);
        memset(vis,0,sizeof vis);
        for(i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                sum+=a[i];
            }
            sort(a,a+n,cmp);
            if(sum%4!=0||a[0]>sum/4)
                printf("no\n");
            else if(dfs(0,0,0))
                printf("yes\n");
            else
                printf("no\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值