Partitioning by Palindromes - UVa 11584 dp

Problem H: Partitioning by Palindromes

Can you read upside-down?

We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, 'racecar' is a palindrome, but 'fastcar' is not.

partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition of 'racecar' into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

  • 'racecar' is already a palindrome, therefore it can be partitioned into one group.
  • 'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
  • 'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').

Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1
7
3

题意:给你一个字符串,问你它至少由多少个回文串构成。

思路:dp[i][j]表示从i到j是不是一个回文串,num[i]表示从第一个字符到第i个字符至少由多少个回文串构成。(好吧,我承认变量名其实倒过来更好一点)

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[1010][1010],num[1010],INF=1000000000;
char s[1010];
int main()
{ int t,i,j,k,n;
  scanf("%d",&t);
  while(t--)
  { scanf("%s",s+1);
    n=strlen(s+1);
    memset(dp,0,sizeof(dp));
    for(i=1;i<=n;i++)
    { dp[i][i]=1;
      dp[i+1][i]=1;
    }
    for(i=n;i>=1;i--)
     for(j=i+1;j<=n;j++)
      if(s[i]==s[j] && dp[i+1][j-1]==1)
       dp[i][j]=1;
    num[1]=1;
    for(j=2;j<=n;j++)
    { num[j]=num[j-1]+1;
      for(i=j-1;i>=1;i--)
       if(dp[i][j]==1)
        num[j]=min(num[j],num[i-1]+1);
    }
    printf("%d\n",num[n]);
  }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值