POJ 3259 Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES
这个题题目意思让我想了好久,结果就是问你有不负坏,使得时光倒流,还各种WA。
LANGUAGE:C++
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>

using namespace std;

const int INF = 1<<31-1;

int n, m, ww;
int d[55000];
int cnt;

struct node
{
    int to;
    int next;
    int weight;
} e[60000];

int lastshow[40000], num[40000];

void insert(int a, int b, int w)
{
    e[++cnt].to = b;
    e[cnt].weight = w;
    e[cnt].next = lastshow[a];
    lastshow[a] = cnt;
}

bool spfa()
{
    queue<int>q;
    bool inqueue[40000]={0};
    q.push(1);
    inqueue[1]=true;
    num[1] ++;
    while(!q.empty())
    {
        int x = q.front();
        q.pop();
        inqueue[x] = false;
        int id = lastshow[x];
        while(id != -1)
        {
            if(d[x] < INF && d[e[id].to] > e[id].weight + d[x])
            {
                d[e[id].to] = e[id].weight + d[x];
                if(!inqueue[e[id].to])
                {
                    inqueue[e[id].to] = true;
                    q.push(e[id].to);
                }
                num[id]++;
                if( num[id] > n )//如果入队的次数超过总数,说明存在回路
                    return true;
            }
            id = e[id].next;
        }
    }
    return false;
}

int main()
{
    int f,i;
    int a, b, w;
    cin >> f;
    while(f -- )
    {
        cnt = 0;
        scanf("%d %d %d", &n, &m, &ww);
        memset(lastshow,-1,sizeof(lastshow));
        memset(num, 0, sizeof(num));
        for(i = 1; i <= n; ++ i)
            d[i]=INF;
        d[1]=0;
        for(i = 1; i <= m; i ++)
        {
            scanf("%d %d %d", &a, &b, &w);
            insert(a, b, w);
            insert(b, a, w);
        }
        for(i = 1; i <= ww; i ++)
        {
            scanf("%d %d %d", &a, &b, &w);
            insert(a, b, -w);
        }
        if(spfa())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值