C - 实在找不到中文题目了

这篇博客探讨了在算法实现中如何运用Dijkstra算法避免超时问题,提出了通过构造反向图来优化效率的思路,强调了逆向思维在解决问题中的重要性。
摘要由CSDN通过智能技术生成

Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input

There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home. 
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes . 
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations. 
 

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input

    
    
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output

    
    
1 -1



我的dijkstra  +构造反向图

不然每个点算一次必然超时

逆向思维

#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
#include <iostream>
using namespace std;
#define INF 0x7F800000
int mtx[1005][1005]; 
int be[1005];
int vis[1005];
int dist[1005];

int main()
{
	int t,n,i,p,j,k,m,kk,pp,begin,end,kkpp,w,s,ans;
	while(	scanf("%d%d%d",&n,&m,&s)!=EOF)
	{
	 
		
		memset(mtx,0,sizeof(mtx));
		memset(vis,0,sizeof(vis));
		memset(dist,0,sizeof(dist));
		
		
		int minway;
		
		for (p=1;p<=m;p++)
		{
			scanf("%d%d",&pp,&kk);
			scanf("%d",&kkpp);
			
			if (	mtx[kk][pp]==0)
			{	
				mtx[kk][pp]=kkpp;
			}
			if (kkpp<mtx[kk][pp] && mtx[kk][pp]!=0)
			{	
				mtx[kk][pp]=kkpp;
			}	
		}
	

	 
			ans=0;
		/*		 			for (p=1;p<=n;p++)
		{	for (k=1;k<=n;k++)
			{
			printf("%d ",mtx[p][k]);
			}
			printf("\n");
			}
		*/ 	
			begin=s;
			
			 
			vis[begin]=1;	
			
			
			for (j=1;j<=n;j++)        //创建第一组dist
			{
				if ( (mtx[begin][j])!=0 || (begin==j) )
					dist[j]=mtx[begin][j];
				else 
					dist[j]=INF;
			}
			
			for (k=1;k<=n;k++)                     //不断更新dist
			{
				minway=INF;
				int minpoint;
				
				for (j=1;j<=n;j++)                     //不断更新dist
				{
					
					if ( vis[j]==0 && dist[j]<minway  )  //找到最小加权边与点
					{
						minway=dist[j];
						minpoint=j;
					}
				}
				if(minway == INF) break;         //HEHE
				
				vis[minpoint]=1;
				
				for (j=1;j<=n;j++)                    //不断更新dist
				{
					
					if (mtx[minpoint][j]+minway<dist[j]&&vis[j]!=1&&mtx[minpoint][j]!=0) 
						dist[j]=mtx[minpoint][j]+minway;
				} 
			}
	scanf("%d",&w);
	ans = INF;
		for (i=1;i<=w;i++)
		{
			
			scanf("%d",&end);
	 
		if (ans>dist[end])
						ans=dist[end];
 
		}
		if (ans ==INF) printf("-1\n" );else
	    printf("%d\n", ans );
	}
	return 0;
}       

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值