POJ - 2594 Treasure Exploration (有向无环图的最少可相交路径覆盖)

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

题解:

与求有向无环图的最少不相交路径覆盖的方法一样,只是要先用Floyd求传递闭包。具体传递闭包求法很简单看代码就行了。

代码:

#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN = 505;

bool map[MAXN][MAXN];

struct Edge{
	int next,to;
}E[MAXN*MAXN];

int head[MAXN*2],tot;

inline void Add(int from,int to){
	E[++tot].next = head[from];
	E[tot].to = to;
	head[from] = tot;
}

//------------求传递闭包------------------------------
void Floyd(int N){ 
	for(int k=1 ; k<=N ; ++k)
		for(int i=1 ; i<=N ; ++i)
			for(int j=1 ; j<=N ; ++j){
				if(map[i][j])continue;
				if(map[i][k] && map[k][j]){
					map[i][j] = true;
					Add(i,j+N);
				}
			}
}

//-----------------------------------------------------

int pre[MAXN*2];
bool used[MAXN*2];
 
int Find(int x){
	for(int i=head[x] ; i ; i=E[i].next){
		int to = E[i].to;
		if(used[to])continue;
		used[to] = true;
		if(pre[to] == 0 || Find(pre[to])){
			pre[to] = x;
			return 1;
		}
	}
	return 0;
}

inline void init(){
	memset(map,false,sizeof map);
	memset(pre,0,sizeof pre);
	memset(head,0,sizeof head);
	tot = 0;
}

int main(){
	
	int N,M;
	while(scanf("%d %d",&N,&M) && (N||M)){
		init();
		int from,to;
		for(int i=1 ; i<=M ; ++i){
			scanf("%d %d",&from,&to);
			map[from][to] = true;
			Add(from,to+N);
		}
		Floyd(N);
		int sum = 0;
		for(int i=1 ; i<=N ; ++i){
			memset(used,false,sizeof used);
			sum += Find(i);
		}
		printf("%d\n",N-sum);
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值