uva 315 Network(无向图求割点)

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=82833#problem/B

 UVA链接地址  https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=251

 Network 
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0.

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

题目大意:
给你一个无向图,求其中割点的个数目。
输入数据
第一行一个 n 代表有 n 个点
接下来有多行,一直到读入一个 0,算整个地图的读入结束,再读入一个0,文件数据结束。
每行有第一个数字a,代表接下来的数字都 和 a 相连。 

知识汇总:
割点:无向连通图中,如果删除某点后,图变成不连通了,则称该点为割点。
这里割点 和 桥 都是无向图里的概念,大家在这里不要混淆了。

求割点
一个顶点u是割点,当且仅当满足(1)或(2)
(1) u为树根,且u有多于一个子树。
(2) u不为树根,且满足存在(u,v)为树枝边(或称 父子边,即u为v在搜索树中的父亲),使得 dfn(u)<=low(v)。(也就是说 V 没办法绕过 u 点到达比 u dfn要小的点)
注:这里所说的树是指,DFS下的搜索树。

求割点 tarjan里 low  和  dfn
dfn[u]定义和前面类似,但是low[u]定义为u
或者u的子树中能够通过非父子边追溯到的
最早的节点的DFS开始时间
在Tarjan算法求割点我们要加一个数组 Father[u], 判断两者是否是父子边
///#pragma comment (linker, "/STACK:102400000,102400000")

#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 3010
#define INF 0xfffffff
#define PI acos (-1.0)
#define EPS 1e-8
#define met(a, b) memset (a, b, sizeof (a))

vector <vector <int> > G;
int n, Time, vis[N], low[N], dfn[N], f[N];

void Init ();
int solve ();
void Tarjan (int u, int fa);

int main ()
{
    while (scanf ("%d", &n), n)
    {
        Init ();
        int a, b;
        char ch;

        while (scanf ("%d", &a), a)
        {
            while (scanf ("%d%c", &b, &ch))
            {
                G[a].push_back (b);
                G[b].push_back (a);
                if (ch == '\n') break;
            }
        }
        printf ("%d\n", solve ());
    }
    return 0;
}

void Init ()
{
    G.clear ();
    G.resize (n+1);

    met (low, 0);
    met (dfn, 0);
    Time = 0;
}

int solve ()
{
    int ans = 0, rt = 0;
    met (vis, 0);
    Tarjan (1, 0);

    for (int i=2; i<=n; i++)
    {
        int v = f[i];
        if (v == 1) rt++;
        if (dfn[v] <= low[i]) vis[v] = 1;
    }

    for (int i=2; i<=n; i++)
        if (vis[i]) ans++;
    if (rt > 1) ans++;
    return ans;
}

void Tarjan (int u, int fa)
{
    low[u] = dfn[u] = ++Time;
    f[u] = fa;
    int len = G[u].size (), v;

    for (int i=0; i<len; i++)
    {
        v = G[u][i];
        if (!dfn[v])
        {
            Tarjan (v, u);
            low[u] = min (low[u], low[v]);
        }
        else if (v != fa)
            low[u] = min (low[u], dfn[v]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_大太阳_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值