hdu 5500 Reorder the Books

http://acm.hdu.edu.cn/showproblem.php?pid=5500

Reorder the Books

Problem Description
dxy has a collection of a series of books called "The Stories of SDOI",There are  n(n19)  books in this series.Every book has a number from  1  to  n .

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

One day Evensgn visited dxy's home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing himself in the story,he disrupted the order of the books.

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top. 

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift.
Input
There are several testcases.

There is an positive integer  T(T30)  in the first line standing for the number of testcases.

For each testcase, there is an positive integer  n  in the first line standing for the number of books in this series.

Followed  n  positive integers separated by space standing for the order of the disordered books,the  ith  integer stands for the  ith  book's number(from top to bottom).


Hint:
For the first testcase:Moving in the order of  book3,book2,book1  , (4,1,2,3)(3,4,1,2)(2,3,4,1)(1,2,3,4) ,and this is the best way to reorder the books.
For the second testcase:It's already ordered so there is no operation needed.
Output
For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.
Sample Input
  
  
2 4 4 1 2 3 5 1 2 3 4 5
Sample Output
  
  
3 0

把这题的模型简化一下,有一个1\rightarrow n1n的排列形成的数列,我们要用最少的操作次数把这个数列排序,每次操作都是把一个数放到整个数列的最前面。 首先我们可以注意到每个数最多只会被操作一次。因为假如有一个数被往前拿了两次,显然第一次的操作是没有意义的。 然后能发现一定先操作大的数,再操作小的数。因为假如先把小的数放前面去了,再把大的数放前面去,小的数就又在大的数后面了,小的数必定还得再操作一次,然而操作两次是不划算的。

到这里,对于19的数据范围,我们有一个很暴力的做法,2^n2n枚举要操作哪些数,这些操作按数的大小从大往小的顺序,模拟一下,然后检查一下最后的序列是否有序,复杂度O(n*2^n)O(n2n)

我们很快又能发现,假如操作了大小等于kk的数,那么所有小于kk的数也都得操作了。所以我们不用2^n枚举,直接mm11开始从小到大枚举,表示要操作前mm小的数,然后模拟,验证,这样复杂度为O(n^2)O(n2)

不过其实mm也是不用枚举的。 首先可以发现最大的数nn是不用操作的(其他数操作好了,数"nn"自然就在最后面了)。 于是我们先找到最大的数"nn"的位置,从这个位置往前找,直到找到(n-1)(n1)。假如找到头也没找到(n-1)(n1),那么数"(n-1)(n1)"需要操作,而一旦操作了(n-1)(n1),根据前面结论,总共就需要(n-1)(n1)次操作了;假如找到了(n-1),那么数"(n-1)(n1)"也不需要操作(和数"nn"不需要操作一个道理)。 同理,我们接着从(n-1)(n1)的位置往前找(n-2)(n2),再从(n-2)(n2)的位置往前找(n-3)(n3)...假如数kk找不到了,那么就至少需要kk次操作。这种做法的复杂度是O(n)O(n)

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 3000
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8
#define met(a, b) memset (a, b, sizeof (a))

typedef long long LL;

struct node
{
    char str1[N], str2[N];
    int r1, r2;
    double r;
}p[N], F, q[N];

bool cmp (node a, node b)
{
    return a.r > b.r;
}

int main ()
{
    int t, n, a[N];
    scanf ("%d", &t);

    while (t--)
    {
        scanf ("%d", &n);
        for (int i=1; i<=n; i++)
            scanf ("%d", &a[i]);

        int ans = n;

        for (int i=n; i>=1; i--)
            if (a[i] == ans) ans--;

        printf ("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_大太阳_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值