1010

1010.Reports

Problem Description

Because of Covid-19, Kanade needs to report every time when entering and leaving school. Now you want to check if Kanade’s reports on a certain day are correct.
A sequence of reports is correct if and only if there does not exist two consecutive and same reports.

Input

There are T test cases in this problem.
The first line has one integer T.
For every test case:
The first line has one integer n which denotes the number of times Kanade reported on a certain day.
The second line has n integers a1,a2,a3,⋯,an, ai denotes the type of the i-th report. ai=0 denotes a leaving school report and ai=1 denotes an entering school report.
1≤T≤100
3≤n≤50
0≤ai≤1

Output

For every test case, output ``YES’’ if Kanade’s reports are correct, otherwise output ‘‘NO’’ (without quotes)

Sample Input

4
3
1 1 1
3
1 0 1
5
0 1 0 1 0
4
1 0 1 1

Sample Output

NO
YES
YES
NO

代码:

#include<iostream>
using namespace std;
int array[1000][1000];
int use[1000]; 
int main()
{
	int n;
	cin>>n;
	int i,j,k,flag=1,stanum=0;
	int sum=0;
	for(i=0;i<n*2;i=i+2)
	{
		cin>>array[i][0];
		for(j=0;j<array[i][0];j++)
		{
			cin>>array[i+1][j];
		}
		for(k=0;k<array[i][0]-1;k++)
		{
			if(array[i+1][k]==array[i+1][k+1])
			{
				flag=0;
				break;
			}
			else 
				continue;			
		} 
		if(flag==0)
		{
			use[stanum]=0;
			stanum++;
		}
		else if(flag==1)
		{
			use[stanum]=1;
			stanum++;
		}
		flag=1;
	}
	for(i=0;i<n;i++)
	{
		if(use[i]==0)
			cout<<"NO"<<endl;
		else if(use[i]==1)
			cout<<"YES"<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值