联赛

Problem A

Time Limit: 2000/1000 MS (Java/Others)     Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 485    Accepted Submission(s): 74
Problem Description
Li Lei has many pearls of N different color. The number of each color is limited. Han Mei is Li Lei’s girl friend.
Since Han Mei’s birthday is coming, Li Lei wants to give Han Mei his present for her birthday. Finally, Li Lei decides to make a chain for his lovely girl friend with his beautiful pearls. He wants to make the chain more beautiful, so the number of the continuous pearls with same color is limited.
Now, Li Lei wants to know how long his chain will be. He will always make the chain as long as possible. Pay attention that the shape of a chain is a line but not a circle here.
 
Input
The first line is an integer N. It means that Li Lei has many pearls of N different color.
The next line contains N integers A(0),A(1)……A(N-1). It means that Li Lei has A(i) pearls of the i-th color.
The third line contains N integers B(0),B(1)……B(N-1). It means that in the chain, there will be no more than B(i) continuous pearls of the i-th color.
You can assume that A(i) is not smaller than B(i).
All integers in the input is positive and no larger than 100000.
 
Output
There is one integer in a line for each test case, representing the length of the chain.
 
SampleInput
3
1 1 100
1 1 1
3
1 1 100
1 1 2
 
SampleOutput
5
8

//一道简单的题目:
题意:给你n个不同种类的珠子并且给你相对应应珠子最多可以有几个连在一起,让你求最多可以放多少珠子;
思路:最多的珠子,有可能有剩余或则没有,但是,其它种类的珠子肯定已经最先放完了。这是解题的重点。
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
struct Node
{
    __int64 a;
    __int64 b;
}node[100000];
__int64 cmp(Node aa,Node bb)
{
    return aa.a<bb.a;
}
int main()
{
    int len;
    __int64 ans;
    int i;
    while(scanf("%d",&len)!=EOF)
    {
        memset(node,0,sizeof(node));
        ans=0;
        for(i=0;i<len;i++)
            scanf("%I64d",&node[i].a);
        for(i=0;i<len;i++)
            scanf("%I64d",&node[i].b);
        sort(node,node+len,cmp);
        for(i=0;i<len-1;i++)
        {
            ans+=node[i].a;
        }
        if((ans+1)*node[i].b>=node[i].a)
        {
            ans+=node[i].a;
        }
        else
          ans+=(ans+1)*node[i].b;
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值