sean

系统开发

mplayer1.3.0交叉编译

alsa的依赖库使用的版本是alsa-lib-1.0.27.2,编译配置为:./configure –host=arm-linux-gnueabihf –prefix=/usr/local/alsa –enable-shared –disable-python –with-configdir=/usr/local/alsa/share/alsa –with-plugindir=/usr/local/alsa/lib CC=arm-linux-gnueabihf-gcc CXX=arm-linux-gnueabihf-g++ LD=arm-linux-gnueabihf-ld。注意–with-configdir配置选项,这个是在嵌入式板子上加载配置的路径。
然后是mplayer1.3.0的编译,配置为:
./configure –prefix=/usr/local/mplayer –enable-cross-compile –target=arm-linux-gnueabihf –cc=arm-linux-gnueabihf-gcc –host-cc=gcc-6 –as=arm-linux-gnueabihf-as –ar=arm-linux-gnueabihf-ar –ranlib=arm-linux-gnueabihf-ranlib –enable-alsa –yasm=” –disable-vidix –disable-ossaudio –disable-vdpau –disable-lirc –disable-win32dll –disable-ivtv –disable-dvdnav –enable-fbdev –disable-live –disable-mencoder –disable-mmx –disable-mmxext –disable-sse –disable-sse2 –disable-ssse3 –disable-cmov –extra-cflags=”-I/usr/local/alsa/include -I/usr/local/zlib/include” –extra-ldflags=”-L/usr/local/zlib/lib -L/usr/local/alsa/lib”
该配置测试过在mplayer1.1.0上编译,不成功报如下错误,不知道怎么解决:
libavcodec/arm/dca.h:36:5: error: can’t find a register in class ‘CORE_REGS’ while reloading ‘asm’
libavcodec/arm/dca.h:36:5: error: ‘asm’ operand has impossible constraints

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u010406724/article/details/80353409
文章标签: mplayer alsa
个人分类: linux
想对作者说点什么? 我来说一句

MPlayer-1.3.0.tar.xz

2017年03月23日 12.66MB 下载

嵌入式课件 交叉编译

2011年04月15日 1.11MB 下载

encfs 交叉编译

2018年04月12日 89KB 下载

交叉编译MINIGUI,SQLITE

2011年04月12日 66KB 下载

如何交叉编译 uClinux 内核

2009年03月25日 6.87MB 下载

没有更多推荐了,返回首页

不良信息举报

mplayer1.3.0交叉编译

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭