Parity game

                                                                                                                            Parity game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8258 Accepted: 3221

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3
题意:

有一个由0,1组成的数字串,现在你问一个人,。他会告诉你这一个数字串中第i位到第j位的1的个数为奇数还是偶数

要你判断前k组这个人回答的都是正确的,到第k+1组,这个人说的是错的,要你输出这个k,要是这个人回答的都是正确的,则输出组数

odd为奇数,even为偶数。

/*
POJ 1733
用的 STL中的map + 并查集
*/

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
#include <map>
using namespace std;

const int MAXN=10010;
int F[MAXN];
int val[MAXN];
int find(int x)
{
    if(F[x]==-1)return x;
    int tmp=find(F[x]);
    val[x]^=val[F[x]];
    return F[x]=tmp;
}
map<int,int>mp;
int tol=0;
int insert(int x)
{
    if(mp.find(x)==mp.end())mp[x]=tol++;
    return mp[x];
}

int main()
{
    int n,m;
    int u,v;
    char str[20];
    while(scanf("%d%d",&n,&m)==2)
    {
        tol=0;
        memset(F,-1,sizeof(F));
        memset(val,0,sizeof(val));
        mp.clear();
        int ans=m;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%s",&u,&v,&str);
            if(u>v)swap(u,v);
            if(ans<m)continue;

            u=insert(u-1);
            v=insert(v);
            //printf("%d %d\n",u,v);

            int tmp;
            if(str[0]=='e')tmp=0;
            else tmp=1;
            int t1=find(u);
            int t2=find(v);


            if(t1==t2)
            {
                if(val[u]^val[v]!=tmp)ans=i;
            }
            else
            {
                F[t2]=t1;
                val[t2]=tmp^val[u]^val[v];
            }

        }
        printf("%d\n",ans);
    }
    return 0;
}
由于题设中说明这个长字串上每一位不是0就是1,所以就十分容易得到以下结论:
                    ->1.当区间(i,j)为even时,区间(i,j)上的和为偶数。
                    ->2.当区间(i,j)为odd时,区间(i,j)上的和为奇数。
从而可以定义以下状态SUM(1,i),顾名思义就是前i位的和,而且显然有SUM(1,i - 1)+SUM(i,j)=SUM(1,j)。
那么对于情况1,SUM(i,j)为偶,则SUM(1,i - 1)与SUM(1,j)相同性质,同偶或同奇。
那么对于情况2,SUM(i,j)为奇,则SUM(1,i - 1)与SUM(1,j)相反性质,一奇一偶。

所以就可以这样想,对于第i位,有两个集合:与SUM(1,i - 1)相同奇偶性的SAME集合,以及与SUM(1,i - 1)相反奇偶性的DIFF集合。
每次输入提示语句,根据SUM(i,j)的奇偶性进行集合的合并:
                    ->1.当区间(i,j)为even时,合并SAME[i-1]与SAME[j],合并DIFF[i-1]与DIFF[j]。
                    ->2.当区间(i,j)为odd时,合并SAME[i-1]与DIFF[j],合并DIFF[i-1]与SAME[j]。
可以把SAME与DIFF放在同一数组PAR里,分成前半部分和后半部分即可,注意数组大小,开小会RE。
由于字串长度的缘故,每次询问给定的i与j可以HASH,直接mod一下hashtable的大小就OK。
而产生矛盾的方法也很容易想到:每次合并完成后查询SAME[ i - 1 ]与DIFF[ i - 1 ]同否同根即可,如果同根就说明矛盾了
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<vector>
#include<set>
#include<map>
using namespace std;
const int MAXN=10010;
int pa[MAXN],s[MAXN];
map<int,int> cnt;
int tol;
int getid(int x)
{
	if(cnt.find(x)==cnt.end()) cnt[x]=tol++;
	return cnt[x];
}
void init()
{
	memset(pa,-1,sizeof(pa));
	memset(s,0,sizeof(s));
	tol=0;
	cnt.clear();
}

int find(int x)
{
	if(pa[x]==-1) return x;
	int t=find(pa[x]);
	s[x]^=s[pa[x]];
	pa[x]=t;
	return pa[x];
}
int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	init();
	int ans=m;
	for(int i=1;i<=m;i++)
	{
		char ss[10];
		int u,v;
		scanf("%d%d%s",&u,&v,ss);
		if(u>v) swap(u,v);
		if(ans<m) continue;
		u=getid(u-1);
		v=getid(v);
		int fu=find(u),fv=find(v);
		int tmp;
		if(ss[0]=='e') tmp=0; 
		else tmp=1;
		if(fu==fv)
		{
			int p=s[u]^s[v];
			if(p!=tmp) ans=i-1;
		}
		else
		{
			pa[fv]=fu;
			s[fv]=s[u]^s[v]^tmp;
		}
	}
	printf("%d\n",ans);
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值